Bug 107868 - Problem with printing and exporting to PDF for multiline text box
Summary: Problem with printing and exporting to PDF for multiline text box
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.6.2 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.4.0 target:5.3.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-05-15 13:39 UTC by Eugenij Shkrigunov
Modified: 2017-05-25 19:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
simple database (11.59 KB, application/vnd.sun.xml.base)
2017-05-15 13:40 UTC, Eugenij Shkrigunov
Details
PDF 1 (8.88 KB, application/pdf)
2017-05-15 13:40 UTC, Eugenij Shkrigunov
Details
PDF 2 (9.02 KB, application/pdf)
2017-05-15 13:40 UTC, Eugenij Shkrigunov
Details
Document which shows multi-line widget failure when printing (11.20 KB, application/vnd.oasis.opendocument.text)
2017-05-17 15:30 UTC, Dave Richards
Details
Before and after patch, note the mis-rendering when printing (496.38 KB, image/jpeg)
2017-05-17 15:31 UTC, Dave Richards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugenij Shkrigunov 2017-05-15 13:39:41 UTC
Hi!

Sorry for my English.

After updating LibreOffice to version 5.2.6.2, there was a problem with printing and exporting to PDF for multiline text box.
In the attachment, an example of a simple database and PDF files demonstrating the problem.
In Libreoffice version 5.2.3.3 there is no problem.
Comment 1 Eugenij Shkrigunov 2017-05-15 13:40:02 UTC
Created attachment 133334 [details]
simple database
Comment 2 Eugenij Shkrigunov 2017-05-15 13:40:30 UTC
Created attachment 133335 [details]
PDF 1
Comment 3 Eugenij Shkrigunov 2017-05-15 13:40:47 UTC
Created attachment 133336 [details]
PDF 2
Comment 4 Julien Nabet 2017-05-15 14:36:08 UTC
On which platform are you? (Linux, Windows, MacOS)
For your information, the last stable LO version is 5.3.3, could you give it a try?
Comment 5 Eugenij Shkrigunov 2017-05-15 14:41:41 UTC
Platform is Linux (Gentoo). I have no 5.3 yet.
Comment 6 Xisco Faulí 2017-05-16 14:46:10 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha1+
Build ID: 74d2e606fd3605fe0a585f596eaa215ae4e20d18
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: fo-FO (ca_ES.UTF-8); Calc: group

Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 7 Dave Richards 2017-05-17 15:30:02 UTC
This bug affected us on 5.3 and I was able to get a bibisect of the commit that broke multi-line text widgets when printing.

f2b66a9dfac451d7f00918085df15b79d03c9d27 is the first bad commit
commit f2b66a9dfac451d7f00918085df15b79d03c9d27
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Feb 16 02:11:07 2017 +0100

    source sha:ee32c7d8083ae1449d6b379034be92995c142da9
    
    source sha:ee32c7d8083ae1449d6b379034be92995c142da9

:040000 040000 6b94778b194d42fb673f204ee2dc98b5ecc4e456 831d4368deb49b3e09387e2cbfe5f52a9b9d4a3b M     instdir



https://gerrit.libreoffice.org/#/c/33781

I'm going to upload my test document which easily replicates this along with a shot of before and after the patch.
Comment 8 Dave Richards 2017-05-17 15:30:56 UTC
Created attachment 133377 [details]
Document which shows multi-line widget failure when printing

For us, we are using CUPS, Linux and HP printers
Comment 9 Dave Richards 2017-05-17 15:31:44 UTC
Created attachment 133378 [details]
Before and after patch, note the mis-rendering when printing
Comment 10 Dave Richards 2017-05-17 15:34:07 UTC
Adding Cc: to Miklos Vajna
Comment 11 Miklos Vajna 2017-05-23 09:12:43 UTC
http://cgit.freedesktop.org/libreoffice/core/commit/?id=919a4ef592b6026a7533a93682f39118fef29ce8

Fixed with this commit, I just can't type bug numbers correctly.
Comment 12 Miklos Vajna 2017-05-23 10:05:33 UTC
And also backported (still with the wrong bug number...) to libreoffice-5-4.
Comment 13 Dave Richards 2017-05-23 11:09:52 UTC
Request please, backport to 5.3 too.  That's the version we have in production and we have held back updates because of this issue.  We have many documents with form controls in them.
Comment 14 Miklos Vajna 2017-05-24 08:00:22 UTC
Done, see <https://gerrit.libreoffice.org/37977>.
Comment 15 Eugenij Shkrigunov 2017-05-24 14:07:59 UTC
Many thanks.
Comment 16 Commit Notification 2017-05-25 19:47:36 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6a66846f50132fab7be6baf516ab6af04acf7e5&h=libreoffice-5-3

tdf#107868 PDF export of editeng fill color: restrict to logic map modes

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.