Bug 107884 - Element focus not noticeable when in dark theme (gtk3)
Summary: Element focus not noticeable when in dark theme (gtk3)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-Linux GTK3 UI-Theming
  Show dependency treegraph
 
Reported: 2017-05-16 00:50 UTC by Hamid
Modified: 2017-09-06 11:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (41.05 KB, image/png)
2017-08-02 18:50 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hamid 2017-05-16 00:50:56 UTC
Hello,

Using GTK3 Breeze:Dark, elements on dialog boxes are not themed to show focus except for textboxes where you input strings - they are shown with blue borders. Because of that moving among elements with tab key is not possible.

I am using KDE Plasma 5.9.4
Comment 1 Buovjaga 2017-05-22 14:52:39 UTC
Confirmed.

I went in KDE settings, Application style, GTK app. style and changed to Breeze-Dark.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: 6b5fc059543c16759abd5eec2576b5b68e96883a
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on May 21st 2017
Comment 2 Yousuf Philips (jay) 2017-08-02 17:39:57 UTC
A screenshot would be helpful.

Is this a gtk3 or kde4 backend issue?
Comment 3 Buovjaga 2017-08-02 18:50:36 UTC
Created attachment 135080 [details]
Screenshot

Yep, sorry, it is seen when launching with SAL_USE_VCLPLUGIN=gtk3

Screenshot shows situation where focus is in the tab and I can switch tabs with arrow keys. There is no indicator, nothing to distinguish from the situation where I am focused somewhere else.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: b66cfdbc1aa43fb42cf881bcc702798e95a50a9c
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on July 23rd 2017
Comment 4 Caolán McNamara 2017-09-06 11:11:15 UTC
If I run gtk3-demo under the default Adwita and go to combo boxes and run that, then click on the string ids and tab to never and shift tab back to string ids I get focus rects in the native gtk3 widgets.

If I then switch to Breeze Dark I get no focus rects, so as far as I can see the bug isn't ours. Perhaps in the theme itself

i.e. https://bugs.kde.org/show_bug.cgi?id=370425