Bug 107886 - FILEOPEN DOCX: No page color behind a table
Summary: FILEOPEN DOCX: No page color behind a table
Status: RESOLVED DUPLICATE of bug 109184
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks:
 
Reported: 2017-05-16 09:14 UTC by Telesto
Modified: 2018-08-18 10:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (14.18 KB, application/odt)
2017-05-16 09:15 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-05-16 09:14:49 UTC
Description:
The page color isn't applied behind a table

Steps to Reproduce:
1. Open attached file
2. Save as DOCX
3. Open DOCX in LibO

Actual Results:  
Page color is purple except for the table

Expected Results:
Also a purple color behind the table (similar to the ODT)


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha1+
Build ID: 8c0be54a7da6262dffe04357121814dd22b5d7fe
CPU threads: 4; OS: Windows 6.2; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-15_01:35:45
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-05-16 09:15:26 UTC
Created attachment 133353 [details]
Example file
Comment 2 tommy27 2017-05-16 12:58:06 UTC
reproducible under Win7x64 using LibO 5.3.2.2
status NEW
Comment 3 Xisco Faulí 2017-05-16 13:02:35 UTC
reproduced in

Version: 5.4.0.0.alpha1+
Build ID: 74d2e606fd3605fe0a585f596eaa215ae4e20d18
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: fo-FO (ca_ES.UTF-8); Calc: group

and

Version: 4.2.0.0.alpha1+
Build ID: fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3

and the background wasn't exported at all before that.
I think the problem is that the table background is white instead of no-fill, but I don't know whether it's the expected behaviour or not.
Comment 4 Telesto 2017-05-16 13:08:50 UTC
> I think the problem is that the table background is white instead of
> no-fill, but I don't know whether it's the expected behaviour or not.

It should probably be no-fill.  
- export the ODT to doc; or 
- open the exported DOCX in Word.
Comment 5 QA Administrators 2018-05-17 02:32:52 UTC Comment hidden (obsolete, spam)
Comment 6 Justin L 2018-08-18 10:17:30 UTC
Fixed in LO 5.4.2 because of bug 109184

*** This bug has been marked as a duplicate of bug 109184 ***