Bug Hunting Session
Bug 107890 - Cannot access an old MS Access Database file (.mdb) using LibreOffice (x64)
Summary: Cannot access an old MS Access Database file (.mdb) using LibreOffice (x64)
Status: RESOLVED DUPLICATE of bug 97579
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 56904
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-16 10:31 UTC by Joseph DeVore
Modified: 2017-05-24 07:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph DeVore 2017-05-16 10:31:48 UTC
Description:
First my bug report/or/Enhancement-request not sure which.. lol
is similar to
https://bugs.documentfoundation.org/show_bug.cgi?id=97579
so I though I would reference it... :/

I have an old Microsoft Access Database file (.mdb) I have not been able to access for a few years or more... I no longer have the old MS Office 2003 or was it 2007 I cannot recall anymore since last time the server was up and running was 2011...  and I was able to access it using I think Open Office and then LibreOffice after the move over to it... but not in a long time...

an excerpt from the header of the .mdb file
- Standard Jet DB
- 4.0
That's all there was for readable text from the head of the file.

here are some Google search results I found on this subject..
https://forum.openoffice.org/en/forum/viewtopic.php?f=15&t=8872
https://forum.openoffice.org/en/forum/viewtopic.php?f=13&t=1771

________________________________________________________________________
... when I try to re-setup this using "connect to an existing database" 
and I select "Microsoft Access" and the mdb file.. it seems to go fine...
it saves an odb file for opening/connecting-to the mdb.. but I get the following 2 errors when I try to access the tables:

- The connection to the data source "database-name" could not be established.

- "SQL Status: HY000

The connection could not be created. May be the necessary data provider is not installed."

Steps to Reproduce:
1. open LibreOffice - base
2. "connect to an existing database" 
3. select "Microsoft Access"
4. select .mdb file (Standard Jet DB 4.0)
5. save the .odb file
6. open the .odb file to read the .mdb file
7. click on tables and get error listed in description.

Actual Results:  
get error listed in description.

Expected Results:
open .odb file to read .mdb file and read tables successfully.. 


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Comment 1 Joseph DeVore 2017-05-16 10:36:01 UTC
I forgot to mention some basic details

I am running 
- Windows 7 Ultimate SP1 x64
- LibreOffice (v5.3.3.2)

and here is my overall systems specs via a CPUz report:
http://valid.x86.fr/ssns8i
Comment 2 Julien Nabet 2017-05-16 12:04:42 UTC
Jean-Pierre: knowing your work about Access part on LO, thought you might be interested in this one.
Comment 3 Alex Thurgood 2017-05-16 15:40:23 UTC
@Joseph : make sure that you aren't being affected by bug 43227
Comment 4 Alex Thurgood 2017-05-16 15:44:15 UTC
Might also be a DUP of bug 97579, see comments 10, 13 and 14
Comment 5 Joseph DeVore 2017-05-16 16:24:11 UTC
(In reply to Alex Thurgood from comment #3)
> @Joseph : make sure that you aren't being affected by bug 43227

I took a look at it.. hmm.. doesn't look like its my problem...

OpenOffice/LibreOffice was able to connect/open/access this old .mdb file(s) before... I don't recall when, but ruffly over 2-4 years ish...
Comment 6 Alex Thurgood 2017-05-17 07:10:51 UTC
(In reply to Joseph DeVore from comment #5)
> (In reply to Alex Thurgood from comment #3)
> > @Joseph : make sure that you aren't being affected by bug 43227
> 
> I took a look at it.. hmm.. doesn't look like its my problem...
> 
> OpenOffice/LibreOffice was able to connect/open/access this old .mdb file(s)
> before... I don't recall when, but ruffly over 2-4 years ish...


@Joseph : did you look at bug 97579 ? In particular, the comments I referred to ? Those comments indicate that it used to be possible to read mdb files when LibreOffice was a 32bit application running on a 32bit DAC/JetDB driver stack. Recent versions of LibreOffice are 64bit, and this appears, at least in some cases, to be problematic.
Comment 7 Joseph DeVore 2017-05-17 07:36:05 UTC
(In reply to Alex Thurgood from comment #6)
> @Joseph : did you look at bug 97579 ? In particular, the comments I referred
> to ? Those comments indicate that it used to be possible to read mdb files
> when LibreOffice was a 32bit application running on a 32bit DAC/JetDB driver
> stack. Recent versions of LibreOffice are 64bit, and this appears, at least
> in some cases, to be problematic.

yeah.. maybe.. That's sounds like it could be the reason...

do u guys have a archived/non-installer version of LO(32bit) I could try out?
maybe it would work.. I install by default 64bit these days as I run 
Windows 7 Ultimate SP1 x64
Comment 8 Joseph DeVore 2017-05-17 07:48:34 UTC
I checked the Daily(Alpha) builds server and  the pre-release server..
and found NOTHING but .msi installers :( >_>

you devs need to add archived versions for loose testing so one is not forced to install over a stable release...
Comment 9 Julien Nabet 2017-05-17 08:13:08 UTC
As I put in https://bugs.documentfoundation.org/show_bug.cgi?id=97579#c16
"
I noticed this link:
https://www.microsoft.com/en-us/download/details.aspx?id=13255
"Microsoft Access Database Engine 2010 Redistributable"

which proposes 32 and 64 bits drivers.
System requirements don't indicate the need to have MSOffice installed (but perhaps it's implicit).
"
Comment 10 Joseph DeVore 2017-05-18 18:24:15 UTC
ooh... O_o
can you guys/devs create a functional(directory structured) archived version of LO 32bit so I can test and see if my Database file opens/access then?
Comment 11 Alex Thurgood 2017-05-19 12:11:51 UTC
Older versions are archived here :


https://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 12 Alex Thurgood 2017-05-19 12:16:14 UTC
There are no simple ziP/archive executables to my knowledge, unless you build a working application directory yourself from the source code.

If you want to install in parallel, this is possible:

https://wiki.documentfoundation.org/Installing_in_parallel/Windows
Comment 13 Joseph DeVore 2017-05-19 13:20:09 UTC
(In reply to Alex Thurgood from comment #12)
> There are no simple ziP/archive executables to my knowledge, unless you
> build a working application directory yourself from the source code.
> 
> If you want to install in parallel, this is possible:
> 
> https://wiki.documentfoundation.org/Installing_in_parallel/Windows

ahh.. That's too bad :( :/ 
VideoLAN(ie  VLC Media Player) creates archive versions for portable and debugging
purposes...

ok so Admin install does loose files.. ok that works...
I created a .cmd bath file so I can make it quicker next time if I am testing a newer version like a beta/nightly...

of to test now.. will post back in a sec.
Comment 14 Joseph DeVore 2017-05-19 13:29:21 UTC
YUP! that did it!

ONLY the x86(32bit) version of LibreOffice would/could open
the MS Access DataBase File... :D ^_^ :(

Tested LO v5.3.3.2 in Administrative Install(loose file) mode...
Comment 15 Julien Nabet 2017-05-19 13:39:13 UTC
Joseph: just for curiosity, did you have a try with https://bugs.documentfoundation.org/show_bug.cgi?id=107890#c9 ?
Comment 16 Joseph DeVore 2017-05-19 13:58:47 UTC
no I didn't try it :/ 
I was concerned about possible system instability after install
ie. probably worried for nothing..
Comment 17 Joseph DeVore 2017-05-24 03:06:43 UTC
Since its a lack of support or bug in the 64bit version of LO...
Do you guys think you can fix it?
Comment 18 Alex Thurgood 2017-05-24 07:46:37 UTC

*** This bug has been marked as a duplicate of bug 97579 ***
Comment 19 Alex Thurgood 2017-05-24 07:51:54 UTC
(In reply to Joseph DeVore from comment #17)
> Since its a lack of support or bug in the 64bit version of LO...
> Do you guys think you can fix it?

That will depend on whether anyone will get around to deciding on this issue:

https://bugs.documentfoundation.org/show_bug.cgi?id=56904