Bug 107900 - Options/language settings/language/User interface always displays same language
Summary: Options/language settings/language/User interface always displays same language
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:5.5.0 target:5.4.0.1
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-05-16 21:09 UTC by Julien Nabet
Modified: 2017-05-20 10:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2017-05-16 21:09:44 UTC
Description:
On pc Debian x6-64 with master sources updated today, I've got always the same language (czech) in User interface whereas when I choose a language, LO uses it.
So only display issue in options.

Steps to Reproduce:
1. Open LO
2. Tools/Options/Language Settings/Language
3. See User interface
4. Change language + restart LO
5. Step 2 again


Actual Results:  
Same user language

Expected Results:
right user language which really corresponds.


Reproducible: Always

User Profile Reset: No

Additional Info:
This bug is very new since I hadn't this in the last days.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Julien Nabet 2017-05-17 19:44:36 UTC
Regression from https://cgit.freedesktop.org/libreoffice/core/commit/?id=45949bf73790b8214a1fcc8492f4ee6faad20780

Noel/melikeyurtoglu: either the quoted patch is wrong or it's lacking something, or I missed something. Could you take a look?

(BTW, I renamed my LO directory profile to avoid side effect and could still reproduce this).
Comment 2 Commit Notification 2017-05-20 10:32:20 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c6c245bd4d759bb0a220e2d057ba1e0a556f9aab

tdf#107900: Revert "tdf#58134 Reset Button in Options Dialogues does not Work with all Options."

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2017-05-20 10:53:58 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=36f1f96f4ae4fa95b2298c9edd9a9041e7c8cec1&h=libreoffice-5-4

tdf#107900: Revert "tdf#58134 Reset Button in Options Dialogues does not Work with all Options."

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.