Bug Hunting Session
Bug 107937 - Slow and flickering rendering
Summary: Slow and flickering rendering
Status: RESOLVED DUPLICATE of bug 105863
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-18 18:26 UTC by Jez
Modified: 2017-05-18 18:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screen capture of bad rendering (878.09 KB, image/gif)
2017-05-18 18:26 UTC, Jez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jez 2017-05-18 18:26:50 UTC
Created attachment 133391 [details]
Screen capture of bad rendering

I've just installed LibreOffice 5 (I had LibreOffice 4 installed before) and the rendering is unfortunately far worse.  I'm not sure what happened but now my dropdown menus flicker a lot when I mouseover them (as well as other graphical elements like checkboxes), and even worse, the text in the LibreOffice Basic editor is VERY slow to redraw when selecting text.  See the attached GIF for a capture.

I tried disabling hardware acceleration and OpenGL, it didn't fix anything.
Comment 1 Jez 2017-05-18 18:34:12 UTC
System info:

Version: 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: en-GB (en_GB); Calc: group
Comment 2 Jez 2017-05-18 18:53:00 UTC
Update:

set SAL_NO_COMMON_LAYOUT=1

... and then running LO makes performance significantly better, although there is still a bit of annoying flickering.
Comment 3 V Stuart Foote 2017-05-18 18:57:44 UTC

*** This bug has been marked as a duplicate of bug 105863 ***