Bug Hunting Session
Bug 107942 - Text is missing in some dialogs with certain old GPUs / remote desktop connections
Summary: Text is missing in some dialogs with certain old GPUs / remote desktop connec...
Status: RESOLVED DUPLICATE of bug 107166
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-05-18 22:22 UTC by Aron Budea
Modified: 2019-02-09 13:33 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (16.64 KB, image/png)
2017-05-18 22:22 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-05-18 22:22:57 UTC
Created attachment 133396 [details]
Screenshot

In certain remote desktop connections text is not written in some dialogs.
One such dialog is Writer's Tools -> AutoText... (see attached screenshot, Name and Shortcut texts are not there)

This is a regression, and has been bibisected to the following commit:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
author		Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 03:15:14 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 13:22:53 (GMT)

"tdf#103831, tdf#100986: Force using GDI when needed"

Khaled, any thoughts what might be causing this? It doesn't even occur in all remote desktop connections, only in certain ones.
Comment 1 V Stuart Foote 2017-05-19 05:45:07 UTC
@Aron, so are the remote sessions to Windows systems via RDP? What OS and version of RDP?

If Windows only, is this another manifestation of see also bug 107166?
Comment 2 Aron Budea 2017-05-19 07:06:53 UTC
The host is a Windows 2008 server system, the client is Windows 7.

Hm, there seems to be some similarity between this and bug 107166, but here the bug is much less aggressive, the text is mostly visible, except in certain dialogs (quite many dialogs, actually).
Comment 3 Xisco Faulí 2017-05-26 11:33:05 UTC Comment hidden (obsolete)
Comment 4 Aron Budea 2017-05-29 01:14:38 UTC
Just managed to reproduce this with an old Matrox Millennium P690, so it's not remote-desktop-only.

Still only a few pieces of text is missing, like in the screenshot, and not all the text, like in bug 107166 (though the two bugs could still be caused by the same change).
Comment 5 Aron Budea 2017-06-09 13:51:42 UTC
As it turns out this is a duplicate, or rather a less serious case of bug 107166.

*** This bug has been marked as a duplicate of bug 107166 ***