Bug 107961 - CRASH: Libreoffice crashes when editing attributes
Summary: CRASH: Libreoffice crashes when editing attributes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.4.0.1 target:5.3.4
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2017-05-19 19:03 UTC by Timur I. Davletshin
Modified: 2017-05-31 15:21 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (12.71 KB, application/vnd.oasis.opendocument.text)
2017-05-19 19:03 UTC, Timur I. Davletshin
Details
backtrace (28.26 KB, text/x-log)
2017-05-21 16:46 UTC, Xisco Faulí
Details
Valgrind trace (37.91 KB, application/x-bzip)
2017-05-29 20:35 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur I. Davletshin 2017-05-19 19:03:59 UTC
Created attachment 133408 [details]
Test file

Steps to Reproduce:
1. Open document from attachment
2. Double-click "КР-НРТК-(2АС-2)" on the first page (bottom right) to edit content, select it by Ctrl+A
3. Remove bold attribute by Ctrl+B — I experience crash on this step
Comment 1 Regina Henschel 2017-05-19 19:38:28 UTC
No crash with Version: 5.4.0.0.alpha1+
Build ID: 965494c544dd8f35ae83b7cf38549009da06c367
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-10_23:06:27
Locale: de-DE (de_DE); Calc: group
Comment 2 Xisco Faulí 2017-05-19 20:33:19 UTC
I can reproduce it in

Version: 5.3.3.2
Build ID: 1:5.3.3~rc2-0ubuntu0.16.10.1~lo0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 5.4.0.0.alpha1+
Build ID: 74d2e606fd3605fe0a585f596eaa215ae4e20d18
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME and adding backportRequest
Comment 3 Timur I. Davletshin 2017-05-20 19:09:02 UTC
(In reply to Xisco Faulí from comment #2)
> I can reproduce it in
> 
> Version: 5.3.3.2
> Build ID: 1:5.3.3~rc2-0ubuntu0.16.10.1~lo0
> CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
> Engine: new; 
> Locale: ca-ES (ca_ES.UTF-8); Calc: group
> 
> but not in
> 
> Version: 5.4.0.0.alpha1+
> Build ID: 74d2e606fd3605fe0a585f596eaa215ae4e20d18
> CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
> Locale: en-US (ca_ES.UTF-8); Calc: group
> 
> Closing as RESOLVED WORKSFORME and adding backportRequest

It is not fixed in 5.4.0.0.beta1 (official 64 bit build for Linux).

Version: 5.4.0.0.beta1
Build ID: 8672113ead4e403c55e31b1d9a3d1e0f3b299577
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 Xisco Faulí 2017-05-21 16:46:10 UTC
Hi Timur,
are you on Ubuntu?
it seems it only crashes when LibreOffice is installed but not when it's compiled from the git repository, odd!
Moving to NEW
Comment 5 Xisco Faulí 2017-05-21 16:46:40 UTC
Created attachment 133436 [details]
backtrace
Comment 6 Timur I. Davletshin 2017-05-21 16:49:11 UTC
(In reply to Xisco Faulí from comment #4)
> Hi Timur,
> are you on Ubuntu?
> it seems it only crashes when LibreOffice is installed but not when it's
> compiled from the git repository, odd!
> Moving to NEW

Yep, I'm using Ubuntu 16.04 64 bit.
Comment 7 Buovjaga 2017-05-24 10:07:06 UTC
Only crashes with gtk3. Not with kde4, gtk or gen.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.3.2
Build ID: 5.3.3-1
CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 8 Timur I. Davletshin 2017-05-24 10:17:19 UTC
(In reply to Buovjaga from comment #7)
> Only crashes with gtk3. Not with kde4, gtk or gen.
> 
> Arch Linux 64-bit, KDE Plasma 5
> Version: 5.3.3.2
> Build ID: 5.3.3-1
> CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: gtk3;
> Layout Engine: new; 
> Locale: fi-FI (fi_FI.UTF-8); Calc: group

As I mentioned earlier, I use gtk2, not gtk3.
Comment 9 Julien Nabet 2017-05-26 10:22:32 UTC
On pc Debian x86-64 with master sources updated 2 days ago, I could reproduce crash with gtk and gtk3 renderings but with gen and kde4 renderings.

Caolán: thought you might be interested in this one since it crashes only with gtk/gtk3.
Comment 10 Caolán McNamara 2017-05-29 12:16:10 UTC
I can't reproduce this.

Julien, seeing as you can, can you get a valgrind trace of the crash with
export VALGRIND=memcheck and get it to crash and see if there's any hints in that
Comment 11 Julien Nabet 2017-05-29 20:35:57 UTC
Created attachment 133701 [details]
Valgrind trace

I updated my local repo with master sources from today and I reproduced the crash with gtk3 rendering.

I attached Valgrind logs
Comment 12 Caolán McNamara 2017-05-30 09:49:41 UTC
Does https://gerrit.libreoffice.org/#/c/38205/ make any difference ?
Comment 13 Julien Nabet 2017-05-30 19:08:07 UTC
(In reply to Caolán McNamara from comment #12)
> Does https://gerrit.libreoffice.org/#/c/38205/ make any difference ?

I tested the patch, no crash with it, Ctrl-B or I works!
Comment 14 Caolán McNamara 2017-05-30 20:33:32 UTC
It worked ?, on the first effort, well there's a special event.
Comment 15 Commit Notification 2017-05-30 20:34:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e55f887be63b00e0966cb34863bb5d52fcac6d1d

Related: tdf#107961 ensure notifyhdl is unset after dispose

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2017-05-30 20:35:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e7ee5921b366d885b1f3edd617764730d2aa03d9&h=libreoffice-5-4

Related: tdf#107961 ensure notifyhdl is unset after dispose

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Caolán McNamara 2017-05-30 20:37:41 UTC
backport to 5-3 in gerrit
Comment 18 Commit Notification 2017-05-31 15:21:36 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cbd8fd58c6d5ad40561b936b1c7f3b75f518b6c2&h=libreoffice-5-3

Related: tdf#107961 ensure notifyhdl is unset after dispose

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.