Bug 107981 - Not possible to reset color to Automatic in form control properties dialog
Summary: Not possible to reset color to Automatic in form control properties dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.4.0.1 target:5.3.4
Keywords: regression
Depends on:
Blocks: Color-Picker-Widget Form-Controls
  Show dependency treegraph
 
Reported: 2017-05-20 22:52 UTC by Yousuf Philips (jay)
Modified: 2017-05-24 08:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2017-05-20 22:52:05 UTC
Steps:
1) Open Writer
2) Insert > Form Control > Textbox
3) Draw the textbox
4) Right-click > Control
5) Change border from 3D to Flat
6) Notice background color and border color are set to Automatic
7) Change the color in both
8) Not possible to change back to Automatic

Regression as we had a simple drop down menu in 5.2 and switched to the color picker widget in 5.3.

Version: 5.4.0.0.alpha1+
Build ID: 296c2296f5565556eea9fab51563050f28bbcafc
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-17_00:33:24
Locale: en-US (en_US.UTF-8); Calc: group

@Caolan: Any thoughts as your input in bug 105855 is of this same color widget buttons appearing in dialogs?
Comment 1 Jacques Guilleron 2017-05-21 15:55:13 UTC
Hi Yousuf,

I reproduce with 
LO 5.4.0.0.alpha1+ Build ID: d89fa2bd4944625e2dbe56d5709a3f126db24f21
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-05-18_07:09:13
Locale: fr-FR (fr_FR); Calc: CL

Under Windows, a custom color is appied but not if your choice comes from the color picker. In this case, on reopening the Textbox dialog, background and border colors are again set to Automatic. Does this have to be separately reported?
Comment 2 Yousuf Philips (jay) 2017-05-21 16:36:08 UTC
(In reply to Jacques Guilleron from comment #1)
> Under Windows, a custom color is appied but not if your choice comes from
> the color picker. In this case, on reopening the Textbox dialog, background
> and border colors are again set to Automatic. Does this have to be
> separately reported?

Yes that would need to be a separate bug and do set this bug number in the 'See Also' of the newly created bug. I tested on Linux and i couldnt reproduce that bug.
Comment 3 Commit Notification 2017-05-22 12:00:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7539c77fd49889015ad3a952009e33fac5324df6

Resolves: tdf#107981 SID_FM_CTL_PROPERTIES colorbox needs a 'default' entry

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-05-22 12:01:13 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ec38d7e228b5476cee1aa1f968ce1f961c87649&h=libreoffice-5-4

Resolves: tdf#107981 SID_FM_CTL_PROPERTIES colorbox needs a 'default' entry

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2017-05-22 12:13:31 UTC
backport to 5-3 in gerrit
Comment 6 Jacques Guilleron 2017-05-23 22:57:19 UTC
No need to report a second issue, this patch has resolved this one too.
Thanks Caolán.
Try with
LO 5.5.0.0.alpha0+ Build ID: 0e6297932252403883a6057feee488e4ee2bc360
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-05-23_00:14:17
Locale: fr-FR (fr_FR); Calc: CL
Comment 7 Commit Notification 2017-05-24 08:37:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c05f35f4f56a1e65b92f4b1bc43b0fa6138d209c&h=libreoffice-5-3

Resolves: tdf#107981 SID_FM_CTL_PROPERTIES colorbox needs a 'default' entry

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.