Bug 108026 - Add more styles by default to the "paragraph styles" toolbar dropdown
Summary: Add more styles by default to the "paragraph styles" toolbar dropdown
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles-Paragraph-Combobox
  Show dependency treegraph
 
Reported: 2017-05-23 11:26 UTC by Timur
Modified: 2017-06-05 20:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2017-05-23 11:26:45 UTC
Since LO 4.1 there are (increased number of) 8 available styles in "paragraph styles" toolbar dropdown. 
Dropdown is used in classic Formatting and new Formatting (Styles) toolbar from Bug 106781.
Since this is the easiest use of paragraph styles, there should be some more frequently used styles available there by default. 
My candidates are: Text Body Indent, Caption, Heading.
Comment 1 Timur 2017-05-23 11:31:00 UTC
Notes:
Help on "paragraph styles" toolbar dropdown https://help.libreoffice.org/index.php?title=Common/Apply_Style should have the image of dropped down list.
Help on Sidebar paragraph styles filer https://help.libreoffice.org/swriter/SFX2_HID_TEMPLATE_FILTER is empty.
So, I'm not sure what "automatic" here means. Alternative proposal is to have those same styles from "automatic" available in "paragraph styles" toolbar dropdown. I'd still miss Caption.
Comment 2 Yousuf Philips (jay) (retired) 2017-05-28 15:40:17 UTC
(In reply to Timur from comment #0)
> Since LO 4.1 there are (increased number of) 8 available styles in
> "paragraph styles" toolbar dropdown. 

Yes in 4.0 we only listed Default Style, Heading 1, Heading 2, Heading 3, and Text Body, while in 4.1+ we added Title, Subtitle, and Quotations.

> Dropdown is used in classic Formatting and new Formatting (Styles) toolbar
> from Bug 106781.

Also in the sidebar. :D

> Since this is the easiest use of paragraph styles, there should be some more
> frequently used styles available there by default. 
> My candidates are: Text Body Indent, Caption, Heading.

The list should be kept small and contain styles that are highly used by even the most basic style user, as we dont want to overwhelm such users with a large list. I dont see such a user using any of the three proposed styles.

Here is MS Word's default list of paragraph styles as a reference.

Normal
No Spacing
Heading 1
Heading 2
Title
Subtitle
Quote
Intensive Quote
List Paragraph
Comment 3 Yousuf Philips (jay) (retired) 2017-05-28 15:43:20 UTC
(In reply to Timur from comment #1)
> Notes:
> Help on "paragraph styles" toolbar dropdown
> https://help.libreoffice.org/index.php?title=Common/Apply_Style should have
> the image of dropped down list.
> Help on Sidebar paragraph styles filer
> https://help.libreoffice.org/swriter/SFX2_HID_TEMPLATE_FILTER is empty.
> So, I'm not sure what "automatic" here means. Alternative proposal is to
> have those same styles from "automatic" available in "paragraph styles"
> toolbar dropdown. I'd still miss Caption.

About this, you should file a separate bug report about it under component Documentation and set it to Block the help meta bug 80430.
Comment 4 Jean-Francois Nifenecker 2017-05-28 17:21:38 UTC
Regarding the default list of paragraph styles in the dropdown, I would consider that "Default Style" and "Heading" are style parents that should not be directly used within documents.

As for "Default Style", this is obviously the parent of all styles. As such, its settings are inherited throughout the whole paragraphs styles heirloom.

The same goes for "Heading" which the common ancestor of all heading/title styles. This style should also be used as a mean of setting the common aspect of its own heirs.

This leads to *not* display them within the paragraph styles list so that users are not encouraged to use them directly. IMO, the two of them should only be accessed using the Stylist and only for the purpose of setting their heirs.
Comment 5 Cor Nouws 2017-05-28 20:25:46 UTC
(In reply to Jean-Francois Nifenecker from comment #4)
> Regarding the default list of paragraph styles in the dropdown, I would
> consider that "Default Style" and "Heading" are style parents that should
> ....
sers are not encouraged to use them directly. IMO, the two of them should
> only be accessed using the Stylist and only for the purpose of setting their
> heirs.

+ 1
Comment 6 Cor Nouws 2017-05-28 20:26:42 UTC
in general, from what I remember people appreciate that the drop down (more or less) only shows what is used in the document.
So I'm not in favor of more styles by default.
Comment 7 Yousuf Philips (jay) (retired) 2017-05-30 06:36:25 UTC
Guess its unanimous that its fine as is.
Comment 8 Timur 2017-05-30 07:33:11 UTC
(In reply to Yousuf Philips (jay) from comment #7)
> Guess its unanimous that its fine as is.

Sorry, how did you conclude that? Because Cor said he is not in favor? Of course I don't agree. 

(In reply to Cor Nouws from comment #6)
> in general, from what I remember people appreciate that the drop down (more
> or less) only shows what is used in the document.

And how do you get to use it or add something? Not so easy. We are speaking here about:
1. adding most frequently used styles, that I find inadequate and dropdown sufficient enough for a few more
2. having similar list here and in "automatic" list from Sidebar, or making distinction what "automatic" means.

(In reply to Yousuf Philips (jay) from comment #2)
> The list should be kept small and contain styles that are highly used by
> even the most basic style user, as we dont want to overwhelm such users with
> a large list. I dont see such a user using any of the three proposed styles.

Not correct. Even if Jean-Francois' note about Heading is accepted, there remains Text Body Indent. I guess it corresponds to MS' List Paragraph that you listed. Personally I use it in any kind of numbering in different documents and that should be more preferable that direct numbering. 

(In reply to Yousuf Philips (jay) from comment #2)
There are more styles available in MSO Word in ribbon styles to what you listed: Subtitle Emphasis, Emphasis, Intense Emphasis, Strong, Subtitle Reference, Intense Reference, Book Title. Checked with 2010 and 2013.
And since this was relevant in setting to WontFix, I set back to New.
Comment 9 Heiko Tietze 2017-05-30 08:00:41 UTC
Potentially infinite and variable lists are in general not the best fit for fix lists like dropdowns and menu (in contrast to the sidebar approach). So we have to decide what to present there - and likely fail for a minority.

What we can do is to allow users to customize the list. Let's call the styles presented in the main menu and the toolbar _favorites_. By default we define some styles as favorites, i.e. H1, H2, Text body..., but allow to toggle this easily with a click on a to-be-introduced icon next to the sidebar style (and/or in the dialog).

If we restrict this ticket to 'more styles by default' I'm in favor of simplicity and WONTFIX.
Comment 10 Timur 2017-05-30 08:20:47 UTC
LO has 8 and MSO 16 styles available by default. Maybe 16 is too much and not all are needed for a normal use (references and books) but 8 is too few and some are missing. I intended to have discussion on adding couple of most useful. And customization is welcome, but in another bug.
Comment 11 Yousuf Philips (jay) (retired) 2017-05-30 08:28:54 UTC
(In reply to Timur from comment #8)
> Sorry, how did you conclude that? Because Cor said he is not in favor? Of
> course I don't agree. 

JBF also wasnt infavour of your suggestion of 'Heading' in comment 4. I've leave it up to Heiko and Stuart to give their opinions and they can close this if they wish.

> And how do you get to use it or add something? Not so easy. We are speaking
> here about:

Quite easy to use and add something by applying it once in the sidebar if it isnt already listed there.

> 1. adding most frequently used styles, that I find inadequate and dropdown
> sufficient enough for a few more

Unfortunately there isnt a means for users to customize what styles are shown by default unless they create a new default template and have those styles applied in the document.

> 2. having similar list here and in "automatic" list from Sidebar, or making
> distinction what "automatic" means.

According to the help[1], Automatic "Displays styles appropriate to the current context.", but yes it would be good to be able to see the same list in the sidebar (bug 108239).

[1] https://help.libreoffice.org/Writer/Styles_in_Writer

> Not correct. Even if Jean-Francois' note about Heading is accepted, there
> remains Text Body Indent. I guess it corresponds to MS' List Paragraph that
> you listed.

So 'List Paragraph' has left indent of 0.5" and LO doesnt import it into another style name, and its closer to 'List Contents' which has 0.39" than 'Text Body Indent' which has 0.2".

> Personally I use it in any kind of numbering in different
> documents and that should be more preferable that direct numbering. 

If you use it for numbering, why not use a numbering style?

> (In reply to Yousuf Philips (jay) from comment #2)
> There are more styles available in MSO Word in ribbon styles to what you
> listed: Subtitle Emphasis, Emphasis, Intense Emphasis, Strong, Subtitle
> Reference, Intense Reference, Book Title. Checked with 2010 and 2013.
> And since this was relevant in setting to WontFix, I set back to New.

Those are character styles and not paragraph styles.

(In reply to Jean-Francois Nifenecker from comment #4)
> Regarding the default list of paragraph styles in the dropdown, I would
> consider that "Default Style" and "Heading" are style parents that should
> not be directly used within documents.

If its decided on whether the style is a style parent or not, Text Body would also be out of the list.
Comment 12 Cor Nouws 2017-05-30 08:41:08 UTC
(In reply to Yousuf Philips (jay) from comment #11)

> Unfortunately there isnt a means for users to customize what styles are
> shown by default unless they create a new default template and have those
> styles applied in the document.

One could consider that as a elegant solution for the people that need more styles by default in all or some documents: use templates or a different default one.
And let's not forget, there is the clear "more styles" at the bottom. The longer the default list the more unlikely that people will see it :p
Comment 13 Yousuf Philips (jay) (retired) 2017-05-30 19:42:33 UTC
(In reply to Heiko Tietze from comment #9)
> What we can do is to allow users to customize the list. Let's call the
> styles presented in the main menu and the toolbar _favorites_. By default we
> define some styles as favorites, i.e. H1, H2, Text body..., but allow to
> toggle this easily with a click on a to-be-introduced icon next to the
> sidebar style (and/or in the dialog).

Doubt we'd able to populate the customized list of favorite paragraph styles into the Style menu, but it should be easy to do it in the toolbar control. I'd be in favour of users customizing the list in the options dialog, in an enhancement like this is created.

> If we restrict this ticket to 'more styles by default' I'm in favor of
> simplicity and WONTFIX.

So closing this as Heiko also agrees.