Bug 108043 - 5.4.0.0.alpha0+, built after April 24, doesn't start on Windows XP and Vista
Summary: 5.4.0.0.alpha0+, built after April 24, doesn't start on Windows XP and Vista
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All Windows (All)
: medium major
Assignee: Eike Rathke
URL:
Whiteboard: target:5.4.0.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-05-24 03:06 UTC by Aron Budea
Modified: 2017-10-05 16:35 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-05-24 03:06:25 UTC
There is an error dialog upon start that there is no entry point GetUserDefaultLocaleName in KERNEL32.DLL.

The entry point is available since Vista:
https://msdn.microsoft.com/en-us/library/windows/desktop/dd318136(v=vs.85).aspx
Comment 1 Aron Budea 2017-05-24 03:19:41 UTC
It's ICU 59. See: http://site.icu-project.org/download/59#TOC-ICU4C-Platform-Support

"The minimum supported version is Windows 7. Windows XP and Windows Vista are no longer supported."
Comment 2 Eike Rathke 2017-05-24 21:51:09 UTC
Probably the only solution on the 5-4 branch would be to unwind back to ICU 58 for the bundled ICU (i.e. reverting the relevant 4 commits) *AND* add support for compiling with ICU 59 for systems that use it (i.e. all places that introduced the ICU_UCHAR_TYPE variable to our configure and makefiles).

Relevant commits are (in reverse order):
e24cd3818821971fe3c52820dafe0f5ccb4b023a
8720877b8b6bc96e330842f7391ae49a21ec2f63
89de6f62ae1e96d2c492cb5cd8f7d313b51e2f98
fabad007c60958f2ff87e8f636ff6a798ad1f963

Commit fabad007c60958f2ff87e8f636ff6a798ad1f963 also has the ICU_UCHAR_TYPE pieces that need to be re-added.
Comment 3 V Stuart Foote 2017-05-24 23:06:31 UTC
Confirming.  On Windows XP Pro SP3 x86 en-US with
buildid=8672113ead4e403c55e31b1d9a3d1e0f3b299577
MsiProductVersion=5.4.0.0.beta1

(In reply to Eike Rathke from comment #2)
> Probably the only solution on the 5-4 branch would be to unwind back to ICU
> 58 ...

Or, is it finally time to put XP out to pasture, and 5.3 is the end of the run?
Comment 4 Buovjaga 2017-05-25 06:26:36 UTC
(In reply to V Stuart Foote from comment #3)
> Confirming.  On Windows XP Pro SP3 x86 en-US with
> buildid=8672113ead4e403c55e31b1d9a3d1e0f3b299577
> MsiProductVersion=5.4.0.0.beta1
> 
> (In reply to Eike Rathke from comment #2)
> > Probably the only solution on the 5-4 branch would be to unwind back to ICU
> > 58 ...
> 
> Or, is it finally time to put XP out to pasture, and 5.3 is the end of the
> run?

FYI, I am trying my best to investigate the situation on Vista (I have to visit someone with Vista as virtual machine approach just drove me crazy). Dropping XP is not controversial because we announced deprecation with 5.3. It would be cool, if Vista still worked and we could announce deprecation with 5.4.

Yet, if even Vista does not work, I would just WONTFIX this for both.
Comment 5 V Stuart Foote 2017-05-25 22:45:35 UTC
Confirming.  On Windows Vista SP2 x86 en-US with
buildid=8672113ead4e403c55e31b1d9a3d1e0f3b299577
MsiProductVersion=5.4.0.0.beta1

We do get a different Entry Point Not Found error: "The procedure entry point ResolveLocaleName could not be located in the dynamic link library KERNEL32.dll"

Same system, 5.3.3.2 comes up cleanly.
Version: 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 2; OS Version: Windows 6.0; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group
Comment 6 ape 2017-05-26 14:55:24 UTC
I confirm this bug.

OS:
Windows XP Pro SP3 x86 RUS;
Windows XP 64-bit Edition SP2 ENU + MUI_RUS.

The latest build "Win-x86@62-TDF" runs in Windows XP is master~2017-04-24_23.35.22_LibreOfficeDev_5.4.0.0.alpha0_Win_x86_en-US_de_ar_ja_q_zt.msi.

The first build "Win-x86@62-TDF" contains this error is master~2017-04-26_22.29.37_LibreOfficeDev_5.4.0.0.alpha0_Win_x86_en-US_de_ar_ja_q_ztz.msi.
Comment 7 Adolfo Jayme 2017-05-26 19:21:00 UTC
I’d say WONTFIX for both systems as well; Vista has also run out of technical support from Microsoft (its Extended Support phase ended on April 11, 2017).
Comment 8 Buovjaga 2017-05-26 19:25:50 UTC
(In reply to Adolfo Jayme from comment #7)
> I’d say WONTFIX for both systems as well; Vista has also run out of
> technical support from Microsoft (its Extended Support phase ended on April
> 11, 2017).

Unfortunately ESC decided that this should be fixed: https://lists.freedesktop.org/archives/libreoffice/2017-May/077779.html

+ does not run on Windows XP and Vista
        + due to the upgrade to ICU 59
        + solution: wind back to internal ICU 58 (Eike)
          + state in the release notes that 5.4 will be the very last release
            supporting Windows XP and Vista
Comment 9 ape 2017-05-27 03:06:35 UTC
(In reply to Adolfo Jayme from comment #7)
> I’d say WONTFIX for both systems as well; Vista has also run out of
> technical support from Microsoft (its Extended Support phase ended on April
> 11, 2017).
-----

Please read this carefully (https://wiki.documentfoundation.org/ReleaseNotes/5.4):

"LibreOffice 5.4: Release Notes: 

Platform Compatibility 

Mac 
- Mac OS X version 10.8 support is deprecated and the next release will require at least Mac OS X 10.9. 

Windows 
- Uwinapi is discontinued." 

Thats all! Windows XP is included in the list of operating systems where LibreOffice-5.4 should run.
Comment 10 ape 2017-05-27 04:17:35 UTC
You can check the running of master~2017-04-24_23.35.22_LibreOfficeDev_5.4.0.0.alpha0_Win_x86_en-US_de_ar_ja_ru_qtz.msi.

I posted it here: https://yadi.sk/d/n7we_gHk3JZgUS
Comment 11 Aron Budea 2017-05-27 04:40:57 UTC
Yes, the "breaking" commits have been listed by Eike in comment 2, see how they start on 2017-04-26, eg.:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=fabad007c60958f2ff87e8f636ff6a798ad1f963
Comment 12 ape 2017-05-27 05:01:05 UTC
(In reply to Aron Budea from comment #11)
> Yes, the "breaking" commits have been listed by Eike in comment 2, see how
> they start on 2017-04-26, eg.:
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=fabad007c60958f2ff87e8f636ff6a798ad1f963

--
Take a look at it:
http://nabble.documentfoundation.org/2-last-master-builds-was-not-start-on-Windows-XP-64-bit-td4213420.html
Comment 13 Buovjaga 2017-05-27 09:04:02 UTC
(In reply to ape from comment #9)
> Thats all! Windows XP is included in the list of operating systems where
> LibreOffice-5.4 should run.

We could very well change the notes to say XP and Vista are no longer supported. 5.4 is not final after all so the release notes are in flux.

XP has been deprecated since 5.3: https://people.gnome.org/~michael/blog/2016-08-03-under-the-hood-5-2.html

"The 5.2.x releases run well on Windows XP, but we cannot be sure how long our tooling will continue to target that platform. As such - while the ESC has no concrete plans to drop Windows XP support, we are 'deprecating' it after the 5.2.x series - meaning that having a modern C++ compiler and a modern Windows build OS base-line have a higher priority. That means that in future it is possible that future major LibreOffice releases may not run on Windows XP; you have been warned."
Comment 14 ape 2017-05-27 10:44:04 UTC
(In reply to Buovjaga from comment #13)
> (In reply to ape from comment #9)
> > Thats all! Windows XP is included in the list of operating systems where
> > LibreOffice-5.4 should run.
---
> 
> We could very well change the notes to say XP and Vista are no longer
> supported. 5.4 is not final after all so the release notes are in flux.
Do you want to cancel Windows XP support two months before the release? Who will allow you do it?
---

> 
> XP has been deprecated since 5.3:
> https://people.gnome.org/~michael/blog/2016-08-03-under-the-hood-5-2.html
LibreOffice-5.3 runs on Windows XP 32-bit and 64-bit Edition very well. Blogs, even developers are not the official documents of the TDF.
---

Sorry for off-top...
Comment 15 Buovjaga 2017-05-27 12:08:25 UTC
(In reply to ape from comment #14)
> Do you want to cancel Windows XP support two months before the release? Who
> will allow you do it?
> > 
> > XP has been deprecated since 5.3:
> > https://people.gnome.org/~michael/blog/2016-08-03-under-the-hood-5-2.html
> LibreOffice-5.3 runs on Windows XP 32-bit and 64-bit Edition very well.
> Blogs, even developers are not the official documents of the TDF.

Well, the deprecation was decided by the Engineering Steering Committee. The fact that it isn't mentioned in the 5.3 release notes is a very unfortunate human error. Note that the wiki pages are not "official documents of the TDF" either as they can be edited by anyone to contain all kinds of nonsense (which has happened before).

Due to the error of not including XP deprecation in 5.3 release notes or official announcement blog it seems WONTFIX is indeed not an option.

Now we have to make an extra effort to include the information in every possible announcement for 5.4.
Comment 16 V Stuart Foote 2017-05-27 13:02:24 UTC
The only thing new here is ICU 59.1 impact on Vista.

ESC will decide what is best for the project, including dropping an unsupported OS without notice if necessary.
Comment 17 Julien Nabet 2017-05-29 13:19:32 UTC
Eike/Michael: I don't know who decides subjects of ESC but I think WinXP and Vista support should be in next ESC. (status for 5.4 first, future 5.5 if possible)
Comment 18 Eike Rathke 2017-05-29 13:32:10 UTC
We'll revert to internal ICU 58 on 5-4.
Comment 19 Commit Notification 2017-05-29 14:43:02 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=617aa72fe2c097183cb9dd73dd378d6fb0145208&h=libreoffice-5-4

Resolves: tdf#108043 Revert "Upgrade to ICU 59.1"

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2017-05-29 16:26:24 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c43a9c0f3e752e03b0d8dd135f67926918d0fb0f&h=libreoffice-5-4

Re-enable building with ICU 59, tdf#108043 follow-up

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Michael Meeks 2017-05-30 09:32:14 UTC
Hi Julien,

> Eike/Michael: I don't know who decides subjects of ESC but I think WinXP
> and Vista support should be in next ESC. (status for 5.4 first,
> future 5.5 if possible)

Anyone can put something on the agenda; just mail me, and/or put it in the LOOL agenda (you'll need to get an account on TDF LDAP though), and all are welcome at the meeting to discuss things / put their point. I'll add this to the agenda =) thanks !

Michael.
Comment 22 Julien Nabet 2017-05-30 19:21:53 UTC
(In reply to Michael Meeks from comment #21)
> Hi Julien,
> 
> > Eike/Michael: I don't know who decides subjects of ESC but I think WinXP
> > and Vista support should be in next ESC. (status for 5.4 first,
> > future 5.5 if possible)
> 
> Anyone can put something on the agenda; just mail me, and/or put it in the
> LOOL agenda (you'll need to get an account on TDF LDAP though), and all are
> welcome at the meeting to discuss things / put their point. I'll add this to
> the agenda =) thanks !

I don't know what a LOOL agenda is and don't have a TDF LDAP (at least I don't think so! :-)), then I'll just mail you if needed :-)
Comment 23 Buovjaga 2017-05-30 19:26:40 UTC
(In reply to Julien Nabet from comment #22)
> (In reply to Michael Meeks from comment #21)
> > Hi Julien,
> > 
> > > Eike/Michael: I don't know who decides subjects of ESC but I think WinXP
> > > and Vista support should be in next ESC. (status for 5.4 first,
> > > future 5.5 if possible)
> > 
> > Anyone can put something on the agenda; just mail me, and/or put it in the
> > LOOL agenda (you'll need to get an account on TDF LDAP though), and all are
> > welcome at the meeting to discuss things / put their point. I'll add this to
> > the agenda =) thanks !
> 
> I don't know what a LOOL agenda is and don't have a TDF LDAP (at least I
> don't think so! :-)), then I'll just mail you if needed :-)

https://user.documentfoundation.org/

then

https://demo.collaboracloudsuite.com/tdf/

But XP and Vista support has already been pretty much hacked out of master, see git log since the past couple of days. So not much to discuss..
Comment 24 ape 2017-06-08 12:38:22 UTC
Version: 5.4.0.0.beta2
Build ID: 3cc1cdd8ee50f144e5514da51800a08119754d8f
CPU threads: 8; OS: Windows 5.2; UI render: default; 
Locale: en-US (en_US); Calc: group

The program runs fine.
Thanks.