Bug 108053 - Orca slow to speak when navigating onto a cell that contains data from a cell that is blank in Calc
Summary: Orca slow to speak when navigating onto a cell that contains data from a cell...
Status: RESOLVED DUPLICATE of bug 71409
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2017-05-24 11:15 UTC by am_dxer
Modified: 2017-05-29 19:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
This is an audio demonstration of typing letters into data cells to demonstrate this bug. (1.69 MB, video/ogg)
2017-05-29 18:52 UTC, am_dxer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2017-05-24 11:15:31 UTC
Description:
When I move to a cell containing data from a cell that is blank, Orca takes a long time to speak the data. I tested this in a version of Master using the gtk3 version of LibreOffice.

Steps to Reproduce:
1. Type data into cells b2 and b3.
2. Notice that navigating between cells b2 and b3 works well.
3. Navigating onto b2 from b1 causes a lag in Orca speech. Navigating onto b3 from b4 causes a slow down as well.

Actual Results:  
Orca takes a long time to speak.

Expected Results:
The cell should be spoken immediately.


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Yousuf Philips (jay) 2017-05-24 16:32:57 UTC
Not able to repo on Orca 3.20.3 on Ubuntu Mate 16.04 with LO 5.4 alpha 1 git build with gtk2 or gtk3.

@am_dxer: Please do mention which Orca version you are testing against, as the issue likely is version specific, which would make it not our bug. :D

@Alex, @Stuart: Can either of you confirm this?
Comment 2 am_dxer 2017-05-24 16:41:37 UTC
I was testing with Orca 3.25 master on Debian Stretch. I will test with some other versions of Orca. As you say, it could be an Orca issue.
Comment 3 am_dxer 2017-05-27 15:05:23 UTC
I can repro in older versions of Orca. CAn you try typing data into more cells? I find that it gets slow when navigating onto and between cells that contain data after I have typed into many cells. For example, after typing data into a column of 30 cells using the down arrow to move focus to the next cell, it becomes very slow. Restarting LibreOffice fixes the slow down. I also find that it is still fast to navigate between blank cells even after the slow down is occurring.
Comment 4 am_dxer 2017-05-27 15:06:59 UTC
The slow down is specifically occurring when navigating between cells after typing the data. I don't notice the slow down when advancing to the next blank cell with the Dow n arrow as I am typing the column.
Comment 5 Yousuf Philips (jay) 2017-05-27 20:11:56 UTC
I filled B2 to H27 with random integer numbers and wasnt able to reproduce. It would be useful if you could supply a sample document and steps of how to repo it with that document, and/or do a screencast, so we can see and hear what you are experiencing.
Comment 6 am_dxer 2017-05-28 00:35:18 UTC
I tested and I was also unable to reproduce using only integers. CAn you try with letters instead of numbers? I was able to reproduce this when putting a single different random letter in each cell.
Comment 7 Yousuf Philips (jay) 2017-05-29 03:30:14 UTC
Tried but still aint able to repo using single words in 3x3 cells.
Comment 8 Alex ARNAUD 2017-05-29 18:37:19 UTC
(In reply to Yousuf Philips (jay) from comment #1)
> Not able to repo on Orca 3.20.3 on Ubuntu Mate 16.04 with LO 5.4 alpha 1 git
> build with gtk2 or gtk3.
> 
> @am_dxer: Please do mention which Orca version you are testing against, as
> the issue likely is version specific, which would make it not our bug. :D
> 
> @Alex, @Stuart: Can either of you confirm this?

I'm also not able to reproduce this issue on LibreOfficeDev 5.5.

Could you provide us a document and a step by step procedure ?

Best regards.
Comment 9 am_dxer 2017-05-29 18:52:43 UTC
Created attachment 133699 [details]
This is an audio demonstration of typing letters into data cells to demonstrate this bug.
Comment 10 Alex ARNAUD 2017-05-29 19:05:02 UTC
(In reply to am_dxer from comment #9)
> Created attachment 133699 [details]
> This is an audio demonstration of typing letters into data cells to
> demonstrate this bug.

OK, thank you very much, I see what you're talking about now. It looks like it is a duplicate of this bug #71409 : https://bugs.documentfoundation.org/show_bug.cgi?id=71409

For me it's the same behavior and result. Can you confirm ?

Best regards.
Comment 11 am_dxer 2017-05-29 19:13:07 UTC
You are correct. I didn't know that the fix for that other bug had been reverted to solve another problem so I thought  this was a new bug.
Comment 12 am_dxer 2017-05-29 19:13:23 UTC

*** This bug has been marked as a duplicate of bug 71409 ***