Bug 108066 - [FILESAVE DOCX] Chart legend font properties not preserved
Summary: [FILESAVE DOCX] Chart legend font properties not preserved
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Bartosz
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Chart Chart-Legends
  Show dependency treegraph
 
Reported: 2017-05-24 15:43 UTC by Gabor Kelemen
Modified: 2018-05-20 13:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from LO 5.3 (13.56 KB, application/vnd.oasis.opendocument.text)
2017-05-24 15:43 UTC, Gabor Kelemen
Details
Example file saved from LO 5.3 (15.00 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-05-24 15:47 UTC, Gabor Kelemen
Details
Docx in Word 2013 and odt in LO 5.3 side by side (150.83 KB, image/png)
2017-05-24 15:47 UTC, Gabor Kelemen
Details
Screenshot of the file saved to docx and the original side by side (78.46 KB, image/png)
2018-01-09 20:41 UTC, Gabor Kelemen
Details
The example file saved from current master (5.65 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-01-09 20:42 UTC, Gabor Kelemen
Details
The original example and the file exported yesterday side by side in Word 2013 and LO 5.4 (63.89 KB, image/png)
2018-01-10 08:33 UTC, Gabor Kelemen
Details
Example .xlsx file created by MS Office 2013 (14.55 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-01-10 22:18 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-05-24 15:43:46 UTC
Created attachment 133534 [details]
Example file from LO 5.3

Description: The font properties of the chart legend is not preserved when the file is saved as DOCX in LibreOffice Writer

Steps to reproduce:
1. Create an empty text document in LibreOffice Writer
2. Insert a Chart
3. Change the Chart legend font property (e.g. font set and size)
4. Save the file as DOCX
5. Reopen the file either in LibreOffice Writer or Microsoft Word 2013

Actual results:
The font properties (e.g. character set, size) reverts to default

Expected results:
The font properties should be preserved
Comment 1 Gabor Kelemen 2017-05-24 15:47:10 UTC
Created attachment 133535 [details]
Example file saved from LO 5.3
Comment 2 Gabor Kelemen 2017-05-24 15:47:28 UTC
Created attachment 133536 [details]
Docx in Word 2013 and odt in LO 5.3 side by side
Comment 3 Xisco Faulí 2017-05-24 16:00:11 UTC
Confirmed in

- Version: 5.4.0.0.alpha1+
Build ID: 74d2e606fd3605fe0a585f596eaa215ae4e20d18
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: en-US (ca_ES.UTF-8); Calc: group

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

- Version: 4.2.0.0.alpha1+
Build ID: fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3

In previous versions the chart wasn't exported at all.
Comment 4 Gabor Kelemen 2018-01-09 20:41:18 UTC
Created attachment 139001 [details]
Screenshot of the file saved to docx and the original side by side

No longer seems to be an issue in:

Version: 6.1.0.0.alpha0+
Build ID: fee2ccddfc228675662e1afe97e41eb66076cb26
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (hu_HU.UTF-8); Calc: group threaded

I think this is a side effect of solving bug #114173
Comment 5 Gabor Kelemen 2018-01-09 20:42:21 UTC
Created attachment 139002 [details]
The example file saved from current master
Comment 6 Gabor Kelemen 2018-01-09 20:43:31 UTC
Bartosz, could you confirm that this is indeed fixed?
Comment 7 Gabor Kelemen 2018-01-10 08:33:46 UTC
Created attachment 139009 [details]
The original example and the file exported yesterday side by side in Word 2013 and LO 5.4

Looks good in Word too.
Comment 8 Bartosz 2018-01-10 15:42:40 UTC
Yes, I have fixed it with Bug 114173.
Now it should work correctly.
Comment 9 Xisco Faulí 2018-01-10 15:59:26 UTC
(In reply to Bartosz from comment #8)
> Yes, I have fixed it with Bug 114173.
> Now it should work correctly.

Should it be closed then ?
Comment 10 Gabor Kelemen 2018-01-10 17:43:19 UTC
(In reply to Xisco Faulí from comment #9)
> (In reply to Bartosz from comment #8)
> > Yes, I have fixed it with Bug 114173.
> > Now it should work correctly.
> 
> Should it be closed then ?

I'd say yes for now.
My team will surely detect if there is something still missing :).
Comment 11 Bartosz 2018-01-10 22:18:55 UTC
Created attachment 139044 [details]
Example .xlsx file created by MS Office 2013