Bug 108069 - Impress Crashing When Transition Rendering Not Available
Summary: Impress Crashing When Transition Rendering Not Available
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.4.0.1 target:5.3.4
Keywords: haveBacktrace
: 97921 103236 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-24 16:56 UTC by Dave Richards
Modified: 2017-05-29 15:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (14.64 KB, text/plain)
2017-05-24 16:56 UTC, Dave Richards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2017-05-24 16:56:37 UTC
Some of the slide transitions in Impress use GL.  When this is not properly available on the workstation, LibreOffice will crash.  In the past in this case, it would just blink and then not make the transition and our users would just pick another one.  But now it's actually crashing.

It would be OK if LO just worked as it did before and fail silently.

Even better would be if it knew these would not work and would gray them out.

Easily replicated, and attaching backtrace.   Let me know what else you need.

An example of one that crashes is "Cube".  Many other ones work fine.
Comment 1 Dave Richards 2017-05-24 16:56:58 UTC
Created attachment 133541 [details]
Backtrace
Comment 2 Julien Nabet 2017-05-26 06:54:56 UTC
I gave a try by sending https://gerrit.libreoffice.org/#/c/38054/ to review
Comment 3 Julien Nabet 2017-05-26 11:14:48 UTC
The patch was wrong, see comment of it.
Comment 4 Julien Nabet 2017-05-26 11:53:39 UTC
Fixed thanks to Caolan's patch, see https://cgit.freedesktop.org/libreoffice/core/commit/?id=0b9b36cafe29916a9fdeac420a49c174adb10c59
Comment 5 Julien Nabet 2017-05-26 11:56:12 UTC
For 5.4 branch, it's done too, see https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-4&id=3e368230eb28cd88a9491f6ca7a16a65e2774263

For 5.3 branch, the patch is on review with https://gerrit.libreoffice.org/#/c/38065/

Let's put this one to FIXED.
Comment 6 Commit Notification 2017-05-29 08:13:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c76aa66c60bde1fd009f097a0b974b65b295d1ab&h=libreoffice-5-3

Resolves: tdf#108069 2nd OpenGLContext::init should dispose earlier results

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Julien Nabet 2017-05-29 08:41:23 UTC
*** Bug 103236 has been marked as a duplicate of this bug. ***
Comment 8 Julien Nabet 2017-05-29 08:43:27 UTC
*** Bug 97921 has been marked as a duplicate of this bug. ***