Bug 108078 - [FILESAVE DOCX] Chart title area fill property lost when saved as DOCX
Summary: [FILESAVE DOCX] Chart title area fill property lost when saved as DOCX
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:6.2.0 target:6.0.7 target:6.1.1
Keywords:
: 114174 (view as bug list)
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2017-05-25 07:56 UTC by Gabor Kelemen
Modified: 2018-10-10 14:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from LO 5.3 (15.48 KB, application/vnd.oasis.opendocument.text)
2017-05-25 07:56 UTC, Gabor Kelemen
Details
Example file saved to docx from LO 5.3 (14.99 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-05-25 07:57 UTC, Gabor Kelemen
Details
Docx in Word 2013 and odt in LO 5.3 side by side (156.44 KB, image/png)
2017-05-25 07:57 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-05-25 07:56:47 UTC
Created attachment 133553 [details]
Example file from LO 5.3

The Chart title area fill property isn't preserved when the document is saved as DOCX. This bug is consistent regardless of the type of the Area Fill, so it can be reproduced with Color, Gradient, Hatching and Bitmap fill.

Steps to reproduce:
1. Create an empty text document in LibreOffice Writer
2. Insert a Chart
3. Insert a Chart title
3. Change the Chart title area fill from None to anything else (Color, Gradient, Hatching or Bitmap)
4. Save the file as DOCX
5. Reopen the file in LibreOffice Writer or Microsoft Word 2013

Actual results:
The chart title area fill disappears.

Expected results:
The chart title area fill should be preserved.
Comment 1 Gabor Kelemen 2017-05-25 07:57:18 UTC
Created attachment 133554 [details]
Example file saved to docx from LO 5.3
Comment 2 Gabor Kelemen 2017-05-25 07:57:38 UTC
Created attachment 133555 [details]
Docx in Word 2013 and odt in LO 5.3 side by side
Comment 3 Jacques Guilleron 2017-05-25 15:05:51 UTC
Hi Gabor,
reproduced with
LO 5.5.0.0.alpha0+ Build ID: 0e6297932252403883a6057feee488e4ee2bc360
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-05-23_00:14:17
Locale: fr-FR (fr_FR); Calc: CL
also with
LO  4.2.0.0.beta1 Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7
& Windows 7 Home
Comment 4 QA Administrators 2018-05-26 02:42:18 UTC Comment hidden (obsolete)
Comment 5 Jacques Guilleron 2018-05-27 11:17:51 UTC
Still there in
LO 6.1.0.0.alpha1+ Build ID: 23c5125148a8110d88385b29570bf0b7d4400458
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-12_00:15:25
Locale: fr-FR (fr_FR); Calc: CL
Comment 6 Commit Notification 2018-07-30 21:54:12 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=051399740e41c6495ed362e78c63e0868bcd180c

tdf#108078 OOXML Export Chart shapes area fill properties

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-07-31 11:11:33 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3cad36dbcad73f41b921cd079317c20e770c249&h=libreoffice-6-0

tdf#108078 OOXML Export Chart shapes area fill properties

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-07-31 11:11:44 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f800d2caf934c58b5845f6e235468ddfc80604f&h=libreoffice-6-1

tdf#108078 OOXML Export Chart shapes area fill properties

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Jacques Guilleron 2018-08-04 13:47:31 UTC
Hi Balazs Varga,

Works as expected in 
LO 6.2.0.0.alpha0+ Build ID: 7e65a0794b7c57210779bb9a6d1f2b2e49eb86e9
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-30_23:37:44
Locale: fr-FR (fr_FR); Calc: 
Thanck you very much.
Comment 10 Bartosz 2018-10-10 14:56:27 UTC
*** Bug 114174 has been marked as a duplicate of this bug. ***