Download it now!
Bug 108079 - FILESAVE DOCX Chart legend size and position not retained
Summary: FILESAVE DOCX Chart legend size and position not retained
Status: RESOLVED DUPLICATE of bug 114173
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: OOXML-Chart Chart-Legends
  Show dependency treegraph
 
Reported: 2017-05-25 08:01 UTC by Gabor Kelemen
Modified: 2018-02-06 23:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from LO 5.3 (15.33 KB, application/vnd.oasis.opendocument.text)
2017-05-25 08:01 UTC, Gabor Kelemen
Details
Example file saved to docx from LO 5.3 (15.04 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-05-25 08:08 UTC, Gabor Kelemen
Details
Docx in Word 2013 and odt in LO 5.3 side by side (159.80 KB, image/png)
2017-05-25 08:08 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-05-25 08:01:36 UTC
Created attachment 133556 [details]
Example file from LO 5.3

The Chart legend size and position changes to the bottom left corner when the document is saved as DOCX.

Steps to reproduce:
1. Create an empty text document in LibreOffice Writer
2. Insert a Chart
3. Reposition and resize the chart legend. We put it below the chart, to have all items in one row 
4. Save the file as DOCX
5. Reopen the file in LibreOffice Writer or Microsoft Word 2013

Actual results:
The chart legend changes size and moves to a different position.

Expected results:
The chart legend should appear consistent with the original ODT file.
Comment 1 Gabor Kelemen 2017-05-25 08:08:09 UTC
Created attachment 133557 [details]
Example file saved to docx from LO 5.3
Comment 2 Gabor Kelemen 2017-05-25 08:08:29 UTC
Created attachment 133558 [details]
Docx in Word 2013 and odt in LO 5.3 side by side
Comment 3 Buovjaga 2017-06-04 12:11:07 UTC
Repro.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: c855400e9686ddd8bcba5691393f839f6f52c966
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 2nd 2017

Win 10
Version: 4.4.7.2
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: fi_FI
Comment 4 Bartosz 2018-02-06 23:02:14 UTC

*** This bug has been marked as a duplicate of bug 114173 ***