Bug Hunting Session
Bug 108090 - HELP Array-functions (constant matrix in Calc) mentions semicolons and pipes as separators; default is different; no info on options
Summary: HELP Array-functions (constant matrix in Calc) mentions semicolons and pipes ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Olivier Hallot
URL:
Whiteboard: target:6.0.0
Keywords:
: 112400 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-25 20:01 UTC by Regina Henschel
Modified: 2017-09-21 12:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2017-05-25 20:01:00 UTC
The help in /help/source/text/scalc/01/04060107.xhp
says in section "Using Inline Array Constants in Formulas"
<quote>
The column separator (separating elements in one row) and the row separator are language and locale dependent. But in this help content, the ';' semicolon and '|' pipe symbol are used to indicate the column and row separators, respectively. For example, in the English locale, the ',' comma is used as the column separator, while the ';' semicolon is used as the row separator.
</quote>
But the help does not mention, where the user can find the actual setting for his version. And the help is missing, that the user can alter this setting.

I suggest (in content, not literally)
The row and column separator can be seen and altered in Tools > Options > Calc > Formula > Separators.

Such information in the help might prevent bug reports like bug 42947 or bug 108087.
Comment 1 Jacques Guilleron 2017-05-26 17:06:07 UTC
I agree.

jacques
Comment 2 Cor Nouws 2017-09-15 20:03:42 UTC
*** Bug 112400 has been marked as a duplicate of this bug. ***
Comment 3 Cor Nouws 2017-09-15 20:04:54 UTC
(In reply to Cor Nouws from comment #2)
> *** Bug 112400 has been marked as a duplicate of this bug. ***

Sure - allow me to change the summary here ;)
Comment 4 Commit Notification 2017-09-21 12:30:42 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=c25389900adcc9915010b1867aa37e691ea05a62

tdf#108090 Clarify array separators in help pages
Comment 5 Cor Nouws 2017-09-21 12:57:02 UTC
thanks Olivier!