Bug 108098 - Sheet comments toggle state should be evaluated when switching sheets
Summary: Sheet comments toggle state should be evaluated when switching sheets
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:5.5.0 target:5.4.0.1
Keywords: implementationError
Depends on:
Blocks: 107258
  Show dependency treegraph
 
Reported: 2017-05-26 00:10 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-06-09 09:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (3.17 MB, video/webm)
2017-05-26 20:27 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-05-26 00:10:33 UTC
Steps:
1. Open Calc
2. Add a comment to B2
3. Show comment in B2
4. Add a new sheet
5. Add a comment to B2
6. Show comment in B2
7. Switch to sheet1
8. View > Comments hides the comments
9. Switch to sheet2
10. View > Comments wont hide the comments as command is in its untoggled position and repeating View > Comments wont solve the issue
11. Switch to sheet1 and View > Comments will show comment
12. Switch to sheet2 and View > Comments will hide comment
13. Switch to sheet1 and View > Comments will hide comment

Version: 5.5.0.0.alpha0+
Build ID: 0e6297932252403883a6057feee488e4ee2bc360
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-22_23:44:32
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Gülşah Köse 2017-05-26 08:16:52 UTC
Not reproducable for me. 10th step hides comment as it's supposed to be

LibreOfficeDev 5.5.0.0.alpha0
Comment 2 Timur 2017-05-26 16:23:47 UTC
As discussed in https://bugs.documentfoundation.org/show_bug.cgi?id=84837#c22: "The code acts on the selected sheet(s)..."

3. Show comment in Sheet1;B2  - View > Comments is toggled, why, does it understand it' the only comment, what about toolbar button?
4. Add a new Sheet2  - View > Comments and button are unavailable, right, because it's for sheet;
6. Show comment in Sheet2;B2  -  View > Comments is toggled and button is not, why? If we add comment to some other cell, it's OK, problem is only in adding comment for the same cell as in Sheet1;
9. Switch to sheet2  - command and button are not toggled, but they should be; 
10. View > Comments wont hide the comments - right

So, I can reproduce. But I won't confirm solely because Gülşah wrote she can't so I kindly ask here to check why.
Comment 3 Yousuf Philips (jay) (retired) 2017-05-26 20:27:58 UTC
Created attachment 133631 [details]
screencast

@Gulsah: Would suggest you download a TDF daily build if you cant repo this on your git build.
Comment 4 Gülşah Köse 2017-05-29 07:36:30 UTC Comment hidden (obsolete)
Comment 5 Gülşah Köse 2017-05-29 13:20:02 UTC
I saw the screencast now. Sorry. I'll try to reproduce that bug and confirm that tonight. And i'll fix it.
Comment 6 Gülşah Köse 2017-05-30 13:08:12 UTC
When add new sheet by click blank bar steps are wrong but add new sheet via "+" yes steps are true. So Confirmed and will be fixed ASAP
Comment 7 Gülşah Köse 2017-06-01 13:14:52 UTC
Fixed with https://gerrit.libreoffice.org/#/c/38310/
Comment 8 Commit Notification 2017-06-07 16:36:49 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=57bdb06703ecf233d12304d4e71e1f40d29da327

tdf#108098 Correct detection of MIXED state.

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-06-07 22:06:38 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=81e7ef8d3941de527f21c1508389c9e09518680b&h=libreoffice-5-4

tdf#108098 Correct detection of MIXED state.

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Timur 2017-06-09 09:42:26 UTC
Tested and looks fixed to me.