Bug 108109 - CRASH: Writer crashes while closing after copy/pasting specific content
Summary: CRASH: Writer crashes while closing after copy/pasting specific content
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All Windows (All)
: highest critical
Assignee: Michael Stahl
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.4.0.1 target:5.3.4
Keywords: bibisected, regression
: 108231 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-26 09:59 UTC by Telesto
Modified: 2017-05-31 08:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["XMLShapeExport::collectShapeAutoStyles(com::sun::star::uno::Reference<com::sun::star::drawing::XShape>%20const%20&)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-05-26 09:59:42 UTC
Description:
Under specific circumstances will crash/hang

Steps to Reproduce:
1. Open attachment 133582 [details] (bug 108092)
2. Copy one of the vertical (text)boxes
3. Open a new document
4. Paste the textbox
5. Close the first opened document
6. Close the newly created document without saving (red cross or file -> exit)
7. LibreOffice will keep running in the background (blocking the clipboard).
Crash report popups after kill the process and restarting LibO

Actual Results:  
Crash; running LibO in the background

Expected Results:
Libreoffice should close properly


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in 
Version: 5.5.0.0.alpha0+
Build ID: d57e6cd9dcc96112994ca2b14ac45896e86b26e5
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-18_22:43:07
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 5.4.0.0.beta1 
Build ID: 8672113ead4e403c55e31b1d9a3d1e0f3b299577
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

crashreport.libreoffice.org/stats/crash_details/2cb179aa-e46f-4449-9113-617998e79346


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Xisco Faulí 2017-05-26 10:17:30 UTC
Confirmed in

Version: 5.4.0.0.alpha1+
Build ID: 74d2e606fd3605fe0a585f596eaa215ae4e20d18
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); Calc: group

and

Versión: 5.3.2.2
Id. de compilación: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
Subproc. CPU: 1; SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group
Comment 2 Xisco Faulí 2017-05-26 10:37:08 UTC Comment hidden (obsolete)
Comment 3 Caolán McNamara 2017-05-29 11:36:10 UTC
the commit identified here is a gtk3 only commit, so the reports about windows cannot be caused by that
Comment 4 Xisco Faulí 2017-05-29 20:21:53 UTC
(In reply to Caolán McNamara from comment #3)
> the commit identified here is a gtk3 only commit, so the reports about
> windows cannot be caused by that

Ok, created bug 108231 for the gtk3 crash. Changing this one to win only.

@Aron, would you mind bisecting this one on Window?
Comment 5 Aron Budea 2017-05-30 04:33:14 UTC
This reminded me of bug 105055, and bibisecting points to the same range of commits as well (~250 commits):
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=3f6ad98c4764402dc6e876106867e49e3e888f8f..c8a94cae37029b037507ce86d149ba56ca341f11

Is there any connection between this and the other, previously fixed bug? No idea.
Comment 6 Commit Notification 2017-05-30 11:37:10 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db38e3f201517acf22c1773ae9fc4cb2514788b1

tdf#108231 tdf#108109 xmloff: SvxUnoDrawingModel doesn't implement...

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Stahl 2017-05-30 11:45:45 UTC
this is caused by the export code for the text box feature

no idea why it started to crash in 5.3, perhaps something about
clipboard handling changed?

fixed on master
Comment 8 Michael Stahl 2017-05-30 11:46:22 UTC
*** Bug 108231 has been marked as a duplicate of this bug. ***
Comment 9 Julien Nabet 2017-05-30 12:02:32 UTC
Michael: taking a look at your comment of https://cgit.freedesktop.org/libreoffice/core/commit/?id=db38e3f201517acf22c1773ae9fc4cb2514788b1,
would it be possible and useful to implement XStyleFamiliesSupplier
with just :
#include <com/sun/star/style/XStyleFamiliesSupplier.hpp>
and 
Reference< XStyleFamiliesSupplier > xFamiliesSupp( GetExport().GetModel(), UNO_QUERY );
(I haven't tested it but perhaps it doesn't worth it for some reasons or can't even work)

Remark: I just took a look to http://opengrok.libreoffice.org/search?q=xStyleFamiliesSupplier&project=core&defs=&refs=&path=xmloff&hist=
Comment 10 Commit Notification 2017-05-30 14:32:06 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d9ae5391e72b91f80d6915d2ff420e191fdc892f&h=libreoffice-5-4

tdf#108231 tdf#108109 xmloff: SvxUnoDrawingModel doesn't implement...

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-05-30 16:00:02 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=024fa6b3915fd84586b348b5033dcc4312cd8926&h=libreoffice-5-3

tdf#108231 tdf#108109 xmloff: SvxUnoDrawingModel doesn't implement...

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2017-05-31 08:18:40 UTC
Verified in

Version: 5.5.0.0.alpha0+
Build ID: 9956849c2ea6049582e2ccf04c355542c1ef00a1
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group