Bug 108183 - EDITING: After a JPG compression in Writer, only a tiny small image gets pasted in Draw
Summary: EDITING: After a JPG compression in Writer, only a tiny small image gets past...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Image-Compression
  Show dependency treegraph
 
Reported: 2017-05-27 18:42 UTC by Telesto
Modified: 2018-01-07 15:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-05-27 18:42:13 UTC
Description:
After a JPG compression in Writer, only a tiny small image gets pasted to Draw. I reported similar behavior before (bug 107986), but that seemed to be cause of missing dpi information. In this example I used perfectly fine images (one JPG one PNG)

Steps to Reproduce:
1. Open the attached file
2. Compress both images context menu -> Compress -> Settings: JPG 90% without reducing the image resolution
3. Copy the top (or bottom) image
4. Open a new Draw Document
5. Paste the image

Actual Results:  
A very tiny images get pasted

Expected Results:
The image should have the same dimensions as in Writer


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.5.0.0.alpha0+
Build ID: d57e6cd9dcc96112994ca2b14ac45896e86b26e5
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-18_22:43:07
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2017-06-04 16:07:20 UTC
You forgot to attach file, but I reproduced with some random image.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: c855400e9686ddd8bcba5691393f839f6f52c966
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 2nd 2017

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.3.2
Build ID: 5.3.3-1
CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 2 Flashman 2017-06-23 09:16:28 UTC
It seems to be related to the wrong interpretation of the resolution settings in the compression menu.

Steps:
1. Insert any image.
2. Double click (properties) / Select the Crop tab / Read dimensions and DPI.
3. Right click image / Compress / Keep note of width, height and DPI selected and then OK.
4. Repeat step 2. Image has now very small size and very high DPI (more than 2500 DPI) and not those selected in step 3.

Clearly everything is fine if, in the compression menu, the reduce image resolution in unchecked.

Reproducible: Always
User Profile Reset: No
Version: 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: it-IT (en_US); Calc: group
Comment 3 Telesto 2017-12-29 15:49:03 UTC
No repro
Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-26_23:10:23
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 Buovjaga 2018-01-07 15:07:05 UTC
(In reply to Telesto from comment #3)
> No repro
> Version: 6.1.0.0.alpha0+
> Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
> CPU threads: 4; OS: Windows 6.3; UI render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-12-26_23:10:23
> Locale: nl-NL (nl_NL); Calc: CL

Same here, closing.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: e1fb3d95ac6d58b60448981e82d90621cad7fea5
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on January 7th 2018