Download it now!
Bug 108201 - [Feature request] Export superscript numbers in footnote fields to HTML
Summary: [Feature request] Export superscript numbers in footnote fields to HTML
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote HTML-Export
  Show dependency treegraph
 
Reported: 2017-05-28 16:06 UTC by Robert Orzanna
Modified: 2018-06-30 13:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Formatting of footnote numbers in the source file (1.77 KB, image/png)
2017-05-28 16:06 UTC, Robert Orzanna
Details
Formatting of footnote numbers in the exported HTML file (2.60 KB, image/png)
2017-05-28 16:06 UTC, Robert Orzanna
Details
Doc Example (1.13 KB, text/html)
2017-06-04 13:04 UTC, Jacques Guilleron
Details
test.odt by Robert (8.32 KB, application/vnd.oasis.opendocument.text)
2017-06-04 13:52 UTC, Robert Orzanna
Details
test.html by Robert (2.75 KB, text/html)
2017-06-04 13:53 UTC, Robert Orzanna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Orzanna 2017-05-28 16:06:24 UTC
Created attachment 133670 [details]
Formatting of footnote numbers in the source file

Dear all, 

Please take a look at the attached screenshots.

Footnote numbers are not exported uppercase to HTML although they are shown as uppercase in the source file. 

Could we add support to export footnote numbers as uppercase in the resulting HTML document? I found footnote numbers that are the same size as the main text very hard to read. 

Thank you!

Robert
Comment 1 Robert Orzanna 2017-05-28 16:06:46 UTC
Created attachment 133671 [details]
Formatting of footnote numbers in the exported HTML file
Comment 2 Jacques Guilleron 2017-06-04 13:04:02 UTC
Created attachment 133843 [details]
Doc Example

Hi Robert,

Works for me with
LO  5.5.0.0.alpha0+ Build ID: 0e6297932252403883a6057feee488e4ee2bc360
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-05-23_00:14:17
Locale: fr-FR (fr_FR); Calc: CL

Which OS are you using? which LO versie too?
Comment 3 Robert Orzanna 2017-06-04 13:52:16 UTC
Dear Jacques, 

I appreciate that you got back to me so promptly. 

Attached the .odt and .html generated on my system:

Ubuntu 17.04 MATE

Version: 5.3.3.2
Build ID: 1:5.3.3~rc2-0ubuntu0.17.04.1~lo0
CPU Threads: 4; OS Version: Linux 4.10; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 Robert Orzanna 2017-06-04 13:52:47 UTC
Created attachment 133845 [details]
test.odt by Robert
Comment 5 Robert Orzanna 2017-06-04 13:53:26 UTC
Created attachment 133846 [details]
test.html by Robert
Comment 6 Jacques Guilleron 2017-06-04 17:59:06 UTC
Ok Robert,

Probably concerns only Linux.
Set again to Unconfirmed.

Thank you.
Comment 7 Robert Orzanna 2017-06-05 04:16:01 UTC
Jacques,

Thank you for your help.

It might also affect the version used, correct?

You tested 5.5 whereas I tested 5.3. 

Maybe it was fixed in 5.5?

Does someone know more?

Yours,

Robert
Comment 8 Jacques Guilleron 2017-06-05 07:53:29 UTC
Hi Robert,

You're right. I used Save, not Export, which doesen't work this way.
Comment 9 Robert Orzanna 2017-06-05 09:52:24 UTC
Dear Jacques, 

Interesting! I can confirm that "Save" puts the footnote numbers uppercase whereas "Export" does not. 

Bug? Feature?

Which one to you use: Save or Export?

Yours,

Robert
Comment 10 QA Administrators 2018-06-28 02:48:16 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug