Download it now!
Bug 108232 - Marco Flotante (floating frame) can not be modified, deleted or modified after inserting
Summary: Marco Flotante (floating frame) can not be modified, deleted or modified afte...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Frame
  Show dependency treegraph
 
Reported: 2017-05-29 21:20 UTC by javier
Modified: 2020-06-10 10:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description javier 2017-05-29 21:20:26 UTC
Description:
When you insert a floating frame to see another external spreadsheet, after inserting it can not be modified, deleted or modified.

Steps to Reproduce:
Every time you try to modify or delete a floating frame

Actual Results:  
Can not modify floating frame object

Expected Results:
To be able to modify or delete the object "floating frame"


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393
Comment 1 m.a.riosv 2017-05-29 23:27:26 UTC
Repro.
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: es-ES (es_ES); Calc: group

Version: 5.5.0.0.alpha0+
Build ID: e2e03ffc2637c9faea8a78f04232644e66ad60c4
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-27_01:24:24
Locale: es-ES (es_ES); Calc: CL

Seems It can only be done just after creation.

The way to select it's with Navigator.
Can be copy/cut/deleted selecting it with the navigator and using the keyboard or the edit menu. But not modify the size.

regression from
Version 3.6.7.2 (Build ID: e183d5b)

first not working
Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)
Comment 2 QA Administrators 2018-05-30 02:38:39 UTC Comment hidden (obsolete)
Comment 3 Thomas Lendo 2019-09-09 19:15:32 UTC
Still reproducible.
Version: 6.4.0.0.alpha0+
Build ID: 4e527f55d74e3220873075a8ec2799e2206fdb2d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-08-31_02:35:57
Comment 4 Buovjaga 2020-06-06 18:06:56 UTC
Steps:
1. Insert - Floating frame
2. Select a Calc document

I don't understand this report from the perspective of it being a regression. What is different between 3.6 and 4.0? To me, all versions behave the same.

(In reply to m.a.riosv from comment #1)
> The way to select it's with Navigator.
> Can be copy/cut/deleted selecting it with the navigator and using the
> keyboard or the edit menu. But not modify the size.

Do you mean the only way to select it is with the Navigator also in 3.6? It is certainly the reality for me. Also with last35onmaster in 43all Linux bibisect repo.
Comment 5 m.a.riosv 2020-06-08 09:47:08 UTC
Seems there is no issue with, after reopen the file, the box of the linked file can be selected with the mouse and edited.
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 75e1cf6c6ea83e65da248dab917b06feea6c18e4
CPU threads: 4; OS: Windows 10.0 Build 19608; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: threaded
Versión: 6.4.4.2 (x64)
Id. de compilación: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
Subprocs. CPU: 4; SO: Windows 10.0 Build 19608; Repres. IU: GL; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES Calc: threaded

Resolved as WFM because don't knew when it was resolved.