Download it now!
Bug 108234 - Border dropdown in Formatting Toolbar Doesn't Account for Adjacent Borders
Summary: Border dropdown in Formatting Toolbar Doesn't Account for Adjacent Borders
Status: RESOLVED DUPLICATE of bug 87787
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-30 00:10 UTC by Kevin
Modified: 2018-10-19 12:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
spreadsheet for 108234 (9.24 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-05-30 00:13 UTC, Kevin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2017-05-30 00:10:31 UTC
Description:
Calc's border logic is badly broken and inferior to Excel.

Steps to Reproduce:
1. open attached spreadsheet
2. select B3 with the intent of removing the white border between B2 and B3
3. in the formmatting toolbar, select the icon for no border

Actual Results:  
nothing happens

Expected Results:
border should be removed


Reproducible: Always

User Profile Reset: No

Additional Info:
The core problem is that while the border the user sees between B2 and B3 uses the same pixels whether it's attached to B2 or B3, there is no way for user to know which cell it's attached to. Invisibly attaching the border to one of the adjacent cells is the design flaw. If not for this, the "Remove Border" checkbox in the Format Cells dialog would be unnecessary, saving literally thousands of unnecessary clicks for the serious user. But this problem is further compounded by the failure to add the functionality of "remove border" to the the Formatting toolbar icon.

My user experience (and I'm approaching 1000 hours of using this program - strictly for formatting - no math), is that Calc is a passive aggressive entity that seeks to tempt with with time-saving features, only to do everything in its power to keep those features from working. Another problem is the "recent colors" display - I haven't figured out the exact bug yet, but it has a way of not showing the correct color. And of course this stems from your ill-advised choice to use different color defaults than Excel. You must realize that almost everyone who uses your program learned on Excel and left Excel because it was so annoying. Why don't you welcome us by making this transition easy and enjoyable instead of being so passive aggressive?

To add insult to injury, you changed the name (and presumably some aspect of) the Remove Borders checkbox when you did the 5.3 version. Why on earth didn't you just fix it then?


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Kevin 2017-05-30 00:12:10 UTC
What I'm trying to say is that the idea that there are two unique borders between adjacent cells is a falsehood. Functionally, there's only one - you can only see one - why should you have to guess which cell it's attached to?
Comment 2 Kevin 2017-05-30 00:13:30 UTC
Created attachment 133705 [details]
spreadsheet for 108234
Comment 3 Buovjaga 2017-06-04 18:13:46 UTC
I think this is covered by bug 87787. Do you agree?
Comment 4 Buovjaga 2017-06-04 18:16:21 UTC
(In reply to Buovjaga from comment #3)
> I think this is covered by bug 87787. Do you agree?

Hmm, well I noticed I already duped one of your reports to it.
Comment 5 Xisco Faulí 2018-10-19 12:21:44 UTC
(In reply to Buovjaga from comment #3)
> I think this is covered by bug 87787. Do you agree?

I agree this can be closed as a dupe of bug 87787

*** This bug has been marked as a duplicate of bug 87787 ***