Bug 108248 - Clear direct formatting doesnt remove paragraph background color
Summary: Clear direct formatting doesnt remove paragraph background color
Status: RESOLVED DUPLICATE of bug 99573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Clear-Formatting DrawingLayer-FillStyles-regressions
  Show dependency treegraph
 
Reported: 2017-05-30 17:14 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-12-25 16:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (14.33 KB, application/vnd.oasis.opendocument.text)
2017-05-30 17:14 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-05-30 17:14:12 UTC
Created attachment 133726 [details]
sample

Steps:
1) Open attached document
2) Notice that step 5 has a paragraph background color
3) Select all (Ctrl + A)
4) Clear Direct Formatting (Ctrl + M)
5) Paragraph background color doesnt disappear
6) Save document
7) Close and reopen it
8) Background color is gone

Regression introduced in 4.4.

Version: 5.5.0.0.alpha0+
Build ID: 6533c30f7f8b62671fef9e636c49b11127812ed1
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-26_02:35:54
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-05-31 09:10:17 UTC
Regression introduced in range: https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=a5e137eb1d37361c60175e8fba780fc46b377a23..5f0d957ac6ea656ab6131a174fe52307f5f6eb2f

Bibisected with bibisect-44max

Adding Cc: to Armin Le Grand
Comment 2 Justin L 2018-12-24 09:47:50 UTC

*** This bug has been marked as a duplicate of bug 99573 ***