Download it now!
Bug 108300 - Several Letterlike Symbols do not upright in vertical layout
Summary: Several Letterlike Symbols do not upright in vertical layout
Status: RESOLVED DUPLICATE of bug 108302
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.beta1
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Vertical-Text
  Show dependency treegraph
 
Reported: 2017-06-02 09:09 UTC by Volga
Modified: 2017-12-08 08:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (10.23 KB, application/vnd.oasis.opendocument.text)
2017-06-02 09:10 UTC, Volga
Details
Screenshot (44.57 KB, image/png)
2017-06-02 09:12 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-06-02 09:09:14 UTC
Description:
Unicode defined vertical orientaion property as U for several Letterlike Symbols (U+2100-214F), but all of them looks not upright in vertical layout.

Steps to Reproduce:
1. Insert a frame and set the text direction as right-to-left (vertical)
2. Copy all Letterlike Symbols into frame
3. Set font as Segoe UI Symbol

Actual Results:  
All Letterlike Symbols looks rotated in vertical layout, althrough they have different vertical orientation properties.

Expected Results:
All Letterlike Symbols should respect their vertical orientation properties in vertical layout.


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.beta1 (x64)
Build ID:8672113ead4e403c55e31b1d9a3d1e0f3b299577
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: zh-CN (zh_CN); Calc: group

In Windows 10 version 1703, Segoe UI and Times New Roman fully support these symbols.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Comment 1 Volga 2017-06-02 09:10:50 UTC
Created attachment 133799 [details]
Test file
Comment 2 Volga 2017-06-02 09:12:01 UTC
Created attachment 133800 [details]
Screenshot
Comment 3 Volga 2017-06-02 09:13:29 UTC
Here is their vertical orientation properties copied from http://www.unicode.org/Public/vertical/revision-17/VerticalOrientation-17.txt

2100 ; U
2101 ; U
2102 ; R
2103 ; U
2104 ; U
2105 ; U
2106 ; U
2107 ; U
2108 ; U
2109 ; U
210A ; R
210B ; R
210C ; R
210D ; R
210E ; R
210F ; U
2110 ; R
2111 ; R
2112 ; R
2113 ; U
2114 ; U
2115 ; R
2116 ; U
2117 ; U
2118 ; R
2119 ; R
211A ; R
211B ; R
211C ; R
211D ; R
211E ; U
211F ; U
2120 ; U
2121 ; U
2122 ; U
2123 ; U
2124 ; R
2125 ; U
2126 ; R
2127 ; U
2128 ; R
2129 ; U
212A ; R
212B ; R
212C ; R
212D ; R
212E ; U
212F ; R
2130 ; R
2131 ; R
2132 ; R
2133 ; R
2134 ; R
2135 ; U
2136 ; U
2137 ; U
2138 ; U
2139 ; U
213A ; U
213B ; U
213C ; U
213D ; U
213E ; U
213F ; U
2140 ; R
2141 ; R
2142 ; R
2143 ; R
2144 ; R
2145 ; U
2146 ; U
2147 ; U
2148 ; U
2149 ; U
214A ; U
214B ; R
214C ; U
214D ; U
214E ; R
214F ; U
Comment 4 Buovjaga 2017-06-10 17:04:55 UTC
Yeah.

Version: 5.5.0.0.alpha0+
Build ID: b08217989558addbcaded122a4e7211ae24bbcff
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-31_06:31:36
Locale: fi-FI (fi_FI); Calc: group
Comment 5 Volga 2017-12-07 05:58:47 UTC
Fixed in bug 108302.

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 1d8cb97fea57b81a1ab151b88c2180e646bd401b
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-07_02:07:17
Locale: zh-CN (zh_CN); Calc: group threaded
Comment 6 Xisco Faulí 2017-12-08 08:06:28 UTC

*** This bug has been marked as a duplicate of bug 108302 ***