Download it now!
Bug 108336 - GTK3: Menubar need click to move from one menu to another
Summary: GTK3: Menubar need click to move from one menu to another
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Wayland
  Show dependency treegraph
 
Reported: 2017-06-04 12:40 UTC by Arnaud Versini
Modified: 2018-07-31 09:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arnaud Versini 2017-06-04 12:40:08 UTC
Description:
Hi,

There is  a regression in menubar on GTK3, we now need to move from menu with keyboard or by cliking on it, and before

Steps to Reproduce:
1.Launch LibreOffice master with GTK3
2.Go to the menu bar and select one menu by clicking on it
3.Move to another menu by moving mouse on it

Actual Results:  
The new menu is not selected

Expected Results:
Menu selected


Reproducible: Always

User Profile Reset: No

Additional Info:
I'm on gnome Version 3.24.2 with 


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Arnaud Versini 2017-06-04 12:51:18 UTC
I'm using Wayland.
Comment 2 Jean-Louis Fuchs 2017-08-10 19:45:53 UTC
I have this bug too, I am using Xorg. I'd say this is not wayland related.
Comment 3 Jean-Louis Fuchs 2017-08-10 19:49:41 UTC
My versions:

LibreOffice 5.3.5
Xorg 1.19.3
gtk+3.0 3.22
Comment 4 Xisco Faulí 2017-08-10 21:47:26 UTC
I can't reproduce it in

Versió: 6.0.0.0.alpha0+
ID de la construcció: 0342c5e8086c8200ecadbe9d52dd4ef6a093effb
CPU threads: 4; OS: Linux 4.10; UI render: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group

on Ubuntu 17.04
Comment 5 Jean-Baptiste Faure 2017-09-25 05:17:11 UTC
Not reproducible for me with 
Version: 6.0.0.0.alpha0+
Build ID: a1976555e0ebb9fc1575c2241e8b0878ccb66410
Threads CPU : 4; OS : Linux 4.4; UI Render : par défaut; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: single

built at home under Ubuntu 16.04 x86-64 (Unity).

Best regards. JBF
Comment 6 Xisco Faulí 2017-09-25 08:15:10 UTC
Hello Arnaud,
Is this issue still reproducible with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 7 QA Administrators 2018-07-03 14:16:26 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2018-07-31 09:42:03 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20180731