Download it now!
Bug 108343 - Pivot table (cache) in XLSX corrupted after roundtrip, file crashes Excel
Summary: Pivot table (cache) in XLSX corrupted after roundtrip, file crashes Excel
Status: RESOLVED DUPLICATE of bug 89139
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Pivot-Table-XLSX
  Show dependency treegraph
 
Reported: 2017-06-05 15:35 UTC by Aron Budea
Modified: 2017-09-15 22:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample pivot table created in Excel (13.18 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-06-05 15:35 UTC, Aron Budea
Details
Sample roundtripped with LO 5.4beta1 (22.80 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-06-05 15:38 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-06-05 15:35:49 UTC
Created attachment 133861 [details]
Sample pivot table created in Excel

The attached simple pivot table was created in Excel 2013.
If the file is roundtripped in LibreOffice (just needs to be saved after loading), it opens asking for recovery in Excel, and produces the following report after repairs:
"Repaired Records: PivotTable report from /xl/pivotCache/pivotCacheDefinition1.xml part (PivotTable cache)"

In the repaired file refreshing pivot table data crashes Excel.
Clicking on autofilter dropdown of Country selector also crashes Excel. Note how "(All)" was changed to "- all -" in LibreOffice.

Observed with LO 5.4beta1 & 4.4.0.3 / Windows 7.
Roundtripping with 4.0.0.3 didn't even preserve the pivot table.

This could be the same as bug 89139 in its current state (gives the same message after repairs, crashes Excel the same way). Since the original issue of bug 89139 is gone, and it's preferred to have new bug reports for new issues, I decided to open this instead.
Comment 1 Aron Budea 2017-06-05 15:38:23 UTC
Created attachment 133862 [details]
Sample roundtripped with LO 5.4beta1
Comment 2 Xisco Faulí 2017-06-06 18:34:08 UTC
I can reproduce the repairing dialog in MSO 2010 under wine after a roundtrip with

Version: 5.5.0.0.alpha0+
Build ID: f2d40b8ba172d90be9a43c30cd5cbd62c0e8e548
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

However, MSO 2010 doesn't crash for me
Comment 3 Bartosz 2017-09-02 04:39:32 UTC
Hello Aron.
I have resolved Cache corruption issue in the bug report: tdf#89139.
It should now works fine in LibreoOffice 6.0. I'm closing this bug as fixed.

Please test different pivots, and let me know if it is working correctly.
If you find other corruption issues with pivot, please attach sample to bug report tdf#89139

*** This bug has been marked as a duplicate of bug 89139 ***