Bug 108356 - FILESAVE: Master slide background image set as tiled when exporting to PPTX
Summary: FILESAVE: Master slide background image set as tiled when exporting to PPTX
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: Slide-Background PPTX-MasterSlide
  Show dependency treegraph
 
Reported: 2017-06-05 23:42 UTC by Yousuf Philips (jay) (retired)
Modified: 2021-10-04 11:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The images settings in the example file in ODP and PPTX format (456.65 KB, image/png)
2021-05-03 15:05 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-06-05 23:42:29 UTC
Steps:
1) Open attachment 50289 [details]
2) Save as pptx
3) Open pptx in powerpoint
4) Notice that background image isnt the same
5) Enable master slide mode ( View > Slide Master )
6) Right-click > Format background
7) Notice that 'Tile picture as texture' is enabled

The problem is that we are adding a <a:tile> tag to the exported xml in /ppt/slideMasters/slideMaster.xml.

<p:bg>
  <p:bgPr>
    <a:blipFill>
      <a:blip r:embed="rId2"></a:blip>
      <a:tile /> <!-- here -->
    </a:blipFill>
  </p:bgPr>
</p:bg>

Version: 5.5.0.0.alpha0+
Build ID: ddf8539d97ce044b7df8d51d6ec72ec864b40fb8
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-06-04_22:10:59
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Buovjaga 2017-07-01 18:23:55 UTC
Repro.

Win 8.1 32-bit
MSO 2013
LibreOffice Version: 6.0.0.0.alpha0+
Build ID: cac5c9f6081590b0548d3116bc4cd4a2509ec576
CPU threads: 4; OS: Windows 6.29; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-01_00:41:48
Locale: fi-FI (fi_FI); Calc: group
Comment 2 QA Administrators 2018-07-02 02:35:02 UTC Comment hidden (obsolete)
Comment 3 Lars Jødal 2018-10-05 06:28:08 UTC
Still reproducible with LO 6.1.2.1
Comment 4 QA Administrators 2019-10-06 03:17:57 UTC Comment hidden (obsolete)
Comment 5 NISZ LibreOffice Team 2021-01-14 15:35:45 UTC
Still a problem in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 80497c7d81af36f703d122ac78baa26387a5854d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
Comment 6 NISZ LibreOffice Team 2021-05-03 15:05:20 UTC
Created attachment 171614 [details]
The images settings in the example file in ODP and PPTX format

Still a problem:

The Scale setting becomes unchecked (Width and Height change from 100% to some sizes in cm) and the images position changes from Center to Top Left.

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9c930c4f3109d123c0831d0fcecf9c8b32e5bbc7
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL