Download it now!
Bug 108374 - Bad alloc crash when pasting RTF (in an uncommon circumstance)
Summary: Bad alloc crash when pasting RTF (in an uncommon circumstance)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2017-06-06 20:18 UTC by Telesto
Modified: 2019-10-14 13:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast (719.00 KB, video/x-msvideo)
2017-06-11 10:30 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-06 20:18:18 UTC
Description:
Not sure if it's worth a bug report, but anyway. In very specific circumstances Calc can crash with bad alloc. Probably because of a bug in LibO3.0.0


Steps to Reproduce:
1. Open attachment 133838 [details] (bug 108332) with LibO3.0.0
2. Copy B2
3. Open Writer LiBO5.5.0.0
4. Special Paste -> RTF
5. CRASH

Actual Results:  
Crash

Expected Results:
No crash (a proper error handling)


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.5.0.0.alpha0+
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie 4.0.0.3 (Bouw-id: 7545bee9c2a0782548772a21bc84a9dcc583b89)


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2017-06-10 18:53:16 UTC
I tried this, but don't get RTF as paste option. Nothing crashes it.

Maybe get a trace with Windbg, if you want.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: 2802dca10eef67554a81cb2347d5f648fa6fcd63
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 10th 2017

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Telesto 2017-06-10 19:35:06 UTC
(In reply to Buovjaga from comment #1)
> I tried this, but don't get RTF as paste option. Nothing crashes it.
Hmm.. typed 'Writer' instead of 'Calc'. Step 3 should be Calc

Steps to Reproduce:
1. Open attachment 133838 [details] (bug 108332) with LibO3.0.0
2. Copy B2
3. Open CALC (not Writer) LiBO5.5.0.0
4. Special Paste -> RTF
5. CRASH

Can't give a backtrace atm. No (prebuild) debug builds available.
Comment 3 Buovjaga 2017-06-10 19:48:23 UTC
Ok, I confirm, but it is 3.3 that crashes, so we should ignore it. Let's close.
Comment 4 Telesto 2017-06-10 22:56:58 UTC
(In reply to Buovjaga from comment #3)
> Ok, I confirm, but it is 3.3 that crashes, so we should ignore it. Let's
> close.

Setting back to unconfirmed. LibO 5.5 is crashing when copying B2 with LibO3.3 and paste it into Lib5.5. LibO3.3 doesn't crash while copying as far I know (don't know about pasting). Small modified steps to reproduce

1. Open attachment 133838 [details] (bug 108332) with LibO3.0.0
2. Copy B2
3. Close LibO3.0.0
4. Open Calc in LiBO5.5.0.0
5. Special Paste -> RTF
6. CRASH
Comment 5 Buovjaga 2017-06-11 06:14:32 UTC
(In reply to Telesto from comment #4)
> 5. Special Paste -> RTF

How do you get this in 5.5/master after 3.3 is closed? I only get Unformatted text and no crash.

Now I tried to repro the 3.3 crash upon pasting while they were both running, but I only get "The contents of the clipboard could not be pasted"
Comment 6 Telesto 2017-06-11 10:30:29 UTC
Created attachment 133953 [details]
Screencast

Screencast. It seems to be Win only.
Comment 7 Buovjaga 2017-06-11 11:16:30 UTC
Ok, I can repro on Win with 3.3 as copy source and master crashing.

Unfortunately we are still lacking TB39 debug builds for Win, so can't get a useful backtrace..

Version: 5.5.0.0.alpha0+
Build ID: b08217989558addbcaded122a4e7211ae24bbcff
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-31_06:31:36
Locale: fi-FI (fi_FI); Calc: group
Comment 8 QA Administrators 2018-07-19 02:42:04 UTC Comment hidden (obsolete)
Comment 9 Julien Nabet 2019-06-11 14:31:33 UTC
On Win10 with master sources updated today, I don't reproduce this.
Idem with 6.2.4.2.

I could indeed choose RTF paste, after having:
- opened the initial Calc file
- copyed B2
- closed completely LO
- opened Writer
- from Writer, open Calc
- Special Paste

Any update with a recent LO version?
Comment 10 Telesto 2019-06-11 16:30:10 UTC
Version: 6.4.0.0.alpha0+ (x86)
Build ID: ac14e5613597e7361ce6995dacb1bb5bd55b6b00
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-06_05:09:49
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 11 Julien Nabet 2019-06-11 16:51:09 UTC
Thank you Telesto for your feedback.