Bug 108388 - very slow scrolling in comparison to LO5.2.7.2
Summary: very slow scrolling in comparison to LO5.2.7.2
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2017-06-07 10:24 UTC by Dr. Matthias Weisser
Modified: 2018-02-18 11:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file showing slow scrolling (465.99 KB, application/vnd.oasis.opendocument.text)
2017-06-07 10:24 UTC, Dr. Matthias Weisser
Details
picture file for test file (20.01 KB, image/png)
2017-06-07 10:25 UTC, Dr. Matthias Weisser
Details
Sample File (zipped) (477.42 KB, application/zip)
2017-06-07 15:13 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Matthias Weisser 2017-06-07 10:24:00 UTC
Created attachment 133892 [details]
test file showing slow scrolling

opening the file (with the one picture in folder BILDER) in LO5.3.3.2 takes about 4s on my system. Holding the "Bild down" button the text scrolls downward. This takes ~2min using LO5.3.3.2 - in comparison to ~30s with versions before LO5.3.3.2. like LO5.2.7.2.
Comment 1 Dr. Matthias Weisser 2017-06-07 10:25:38 UTC
Created attachment 133893 [details]
picture file for test file

this picture file can be put in a newly created folder BILDER for access by the test file.
Comment 2 Telesto 2017-06-07 15:13:04 UTC
Created attachment 133898 [details]
Sample File (zipped)

Repro with
Version: 5.5.0.0.alpha0+ (+/-90 seconds)
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL

and with
Version: 5.2.5.0.0+ (+/- 39 seconds)
Build ID: a4d4fbeb623013f6377b30711ceedb38ea4b49f8
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-2, Time: 2016-12-24_14:43:55
Locale: nl-NL (nl_NL); Calc: CL

but not with:
Versie: 4.4.6.3  (+/- 23 seconds)
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL
Comment 3 Telesto 2017-11-01 19:35:09 UTC
No repro with:
Version: 6.0.0.0.alpha1+
Build ID: 13c5dd1d98a480cb01ca8f24242c80e326e4ade8
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-30_23:52:07
Locale: nl-NL (nl_NL); Calc: CL

Setting to WFM. The issue should be solved with LibreOffice 5.3.7.2 and LibreOffice 5.4.3.