Bug 108390 - Add ability to edit document info for PDF files by Draw
Summary: Add ability to edit document info for PDF files by Draw
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-07 11:05 UTC by yousifjkadom
Modified: 2017-06-12 22:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yousifjkadom 2017-06-07 11:05:19 UTC
Hi. 

It will be very useful if adding ability to show & edit meta data (document info) for PDF files opened by L.O draw. 

Document info like:

- Title

- Author

- Date of creation

- Date of last modified

- Producer

- Editor

- Keyword

Also, if you accept to add this feature, do not forget to add other suboption: "Delete all document info"
Comment 1 Xisco Faulí 2017-06-07 14:00:18 UTC
Thanks for reporting the bug.
it seems like a duplicate of bug 33307.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 33307 ***
Comment 2 yousifjkadom 2017-06-07 16:42:11 UTC
Hi. I think you misunderstand me ! 

Bug 33307 talk about edit OFFICE document info (.doc or .docx or .odf ....) BEFORE export it to PDF. No ! I mean other thing !

I talking about edit of document info of ALREADY CREATED PDF file. I do not talking about edit document info BEFORE converting to PDF !
Comment 3 Xisco Faulí 2017-06-07 18:36:04 UTC
Could you please try to see if there's already a reported bug for the problem you're mentioning?
Comment 4 m.a.riosv 2017-06-07 21:30:35 UTC
What LibreOffice does it's import and export the pdf, not really editing the pdf. It's not really a pdf editor.

Maybe those values could be imported at opening the pdf.
Comment 5 Heiko Tietze 2017-06-12 22:19:35 UTC
As m.a.riosv said, PDF editing is out of scope. If you search the Internet you will find plenty of tools for this purpose.