Download it now!
Bug 108394 - EDITING: (BOLD)formatting for multiple cell's isn't working under specific conditions
Summary: EDITING: (BOLD)formatting for multiple cell's isn't working under specific co...
Status: RESOLVED DUPLICATE of bug 39969
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Cells Cell-Direct-Formatting-Parts
  Show dependency treegraph
 
Reported: 2017-06-07 12:41 UTC by Telesto
Modified: 2017-07-26 15:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-07 12:41:35 UTC
Description:
(BOLD)formatting isn't working for multiple cells at once under specific conditions

Steps to Reproduce:
1. Open a new Calc spreadsheet
2. With cell A1 selected: Press CTRL+B
3. Type "ABC DEF"
4. Select ABC and press CTRL+B again (effectively undoing bold)
5. Select DEF and press CTRL+B again (effectively undoing bold) -> Spacing in between ABC and DEF is still bold
6. Make a few copy's of A1 (dragging right cell corner or manual copy paste)
7. Select A1 and press CTRL+B (cell will be bold; working as expected)
8. Undo (CTRL+Z)
9. Select multiple cell and press CTRL+B. Nothing happens

Actual Results:  
BOLD isn't applied, on multiple cell's but working for a single cell

Expected Results:
Bold should be working for multiple cells too


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.5.0.0.alpha0+
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL

and in
LibreOffice 3.5.7.2 
Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2017-06-11 15:25:43 UTC
Repro, except at 7 I had to press Ctrl+B twice, first to remove the bold from the space and second to apply bold to whole cell.

Also, step 9 is true only, if you select both the original A1 and the others at the same time.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: 2802dca10eef67554a81cb2347d5f648fa6fcd63
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 10th 2017
Comment 2 Telesto 2017-06-11 20:35:24 UTC
The extend can be a problem.
1. Open attachment 133856 [details]
2. Selecting all (CTRL+A)
3. Remove or add bold formatting (CTRL+B)
Comment 3 Yousuf Philips (jay) (retired) 2017-06-20 21:46:35 UTC

*** This bug has been marked as a duplicate of bug 39969 ***