Bug 108404 - Calc changes the font attributes of selected text in unpredictable ways
Summary: Calc changes the font attributes of selected text in unpredictable ways
Status: RESOLVED DUPLICATE of bug 112246
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bibisectRequest, regression
Depends on:
Blocks: Calc-Cells Cell-Direct-Formatting-Parts
  Show dependency treegraph
 
Reported: 2017-06-07 23:32 UTC by Kevin
Modified: 2017-09-13 17:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
steps and demonstration included within this spreadsheet (12.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-07 23:34 UTC, Kevin
Details
reproduces bug from scratch in new document - no prestige elite ever used (11.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-19 19:29 UTC, Kevin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2017-06-07 23:32:48 UTC
Description:
Calc changes the font attributes of selected text in unpredictable ways

Steps to Reproduce:
1. open attached spreadsheet 
2. follow steps in spreadsheet

Actual Results:  
Calc changes the font attributes of selected text in unpredictable ways - sometimes changing them, sometimes not, and sometimes changes some attributes while not changing others. 

Expected Results:
If text is selected, and the user types characters, the new characters should retain the font attributes of the selected text.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Kevin 2017-06-07 23:34:12 UTC
Created attachment 133908 [details]
steps and demonstration included within this spreadsheet
Comment 2 Buovjaga 2017-06-11 10:56:49 UTC
Apparently the direction of selection is significant as well. If you select from the direction of the grey text, it inherits the grey color, but does not change to italics.

Works like expected in 3.6, so this is a regression! Lucky you..

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: 2802dca10eef67554a81cb2347d5f648fa6fcd63
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 10th 2017

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 3 Kevin 2017-06-11 19:09:36 UTC
> Works like expected in 3.6, so this is a regression! Lucky you..

- Is 3.6 still downloadable?
Comment 4 Buovjaga 2017-06-11 19:16:33 UTC
(In reply to Kevin from comment #3)
> > Works like expected in 3.6, so this is a regression! Lucky you..
> 
> - Is 3.6 still downloadable?

Well I believe it works even with some newer version, but I only have 3.3 and 3.6 on my Arch Linux because the other version refuse to run.

The old versions are here: https://downloadarchive.documentfoundation.org/libreoffice/old/

Someone can now bibisect this and find out the cause of the problem: https://wiki.documentfoundation.org/QA/Bibisect
Comment 5 Xisco Faulí 2017-06-19 18:15:38 UTC
Regression introduced in range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=7b384313399ee8199cd7241527c3dbc1d50694a2..9e9f863727d12ef1a397bfd9f3b13259ed8d71b1

Bibisected with bibisect-41max
Comment 6 Kevin 2017-06-19 19:29:26 UTC Comment hidden (obsolete)
Comment 7 Thomas Lendo 2017-06-20 23:28:56 UTC
I think it has the same cause as in Bug 107857 "Incorrect Formatting Logic (should be true replace instead of delete+insert)".
Comment 8 Xisco Faulí 2017-09-13 17:31:14 UTC
I think this is a duplicate of bug 112246. At least, the range of commits is very similar...

*** This bug has been marked as a duplicate of bug 112246 ***