Bug Hunting Session
Bug 108423 - Autocorrect while typing not replacing anymore (manually added to Replace-With) i'll, i've, i'm
Summary: Autocorrect while typing not replacing anymore (manually added to Replace-Wit...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium minor
Assignee: László Németh
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2017-06-08 23:12 UTC by babyorcalover
Modified: 2019-04-09 12:09 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description babyorcalover 2017-06-08 23:12:33 UTC
Ever since the last couple of updates, I found that while writing in my document, despite the fact that it is in the personal database to be corrected, simple words such as I'll and I've and I'm will not capitalize properly like they are saved to do so. I am noticing that those are not the only words, but other personal words I have added to my database of saved words that I use frequently (and frequently misspell) are not correcting themselves as I type.
Comment 1 Buovjaga 2017-06-11 14:08:09 UTC
I tried with "i'll" and it is true that it did not correct while typing. I had to select Apply and edit changes.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.3.2
Build ID: 5.3.3-1
CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 2 Timur 2017-11-01 17:19:08 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2017-11-02 16:36:35 UTC
Tried with Safe mode and problem still seen.

The specific language is English (USA)

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha1+
Build ID: fff7097f1ed8493de099d79aa0613ea6b309100a
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 2nd 2017
Comment 4 QA Administrators 2018-11-03 03:50:37 UTC Comment hidden (obsolete)
Comment 5 babyorcalover 2018-11-03 14:38:29 UTC
Problem still present in version 6.0
Comment 6 Timur 2018-11-05 09:21:40 UTC
"i've" is not in autocorrect database, but can be manually added to Replace-With for example for language English-USA.
Worked in 5.0, not in 5.1 and not in 6.1. Looks like regression.
Comment 7 Buovjaga 2018-11-07 18:41:04 UTC
Bisected with win32-5.1 to https://gerrit.libreoffice.org/plugins/gitiles/core/+/e6fade1ce133039d28369751b77ac8faff6e40cb%5E!

tdf#38395 enable smart apostrophe replacement by default

Adding Cc: to László Németh
Comment 8 László Németh 2018-11-07 21:05:59 UTC
It's worth to add i' -> I' capitalization as a default feature for English (as in MSO). I'll check it. Thanks for your report and its forwarding.
Comment 9 Caolán McNamara 2018-12-20 16:56:47 UTC
*** Bug 106164 has been marked as a duplicate of this bug. ***
Comment 10 Xisco Faulí 2019-03-21 09:43:05 UTC
Dear László Németh,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 11 László Németh 2019-04-01 21:05:24 UTC
(In reply to Xisco Faulí from comment #10)
> Dear László Németh,
> This bug has been in ASSIGNED status for more than 3 months without any
> activity. Resetting it to NEW.
> Please assigned it back to yourself if you're still working on this.

Xisco: There is my fix in the gerrit, so I assigned it back. Thanks for your warning!
Comment 12 Commit Notification 2019-04-02 07:35:05 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/376e3a4893356d2eb7c2a5a902b533982e2663ae%5E%21

tdf#108423 autocorrect English word i' -> I’

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2019-04-03 10:46:12 UTC
Issue verified in

Version: 6.3.0.0.alpha0+
Build ID: 93f1c3665fcdc31c36078f179ac37fd69d3ebb00
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@László Németh, thanks for fixing this!

I've cherry-picked it to 6-2 ( https://gerrit.libreoffice.org/#/c/70190/1 ), although it looks more like an enhancement...
Comment 14 László Németh 2019-04-03 10:56:44 UTC
(In reply to Xisco Faulí from comment #13)
> Issue verified in
> 
> Version: 6.3.0.0.alpha0+
> Build ID: 93f1c3665fcdc31c36078f179ac37fd69d3ebb00
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> @László Németh, thanks for fixing this!
> 
> I've cherry-picked it to 6-2 ( https://gerrit.libreoffice.org/#/c/70190/1 ),
> although it looks more like an enhancement...

@Xisco, thanks for verifying and cherry-picking. Yes, it's also an enhancement, but it fixes the regression, too, when the word "i'" is there in a sentence starting position.
Comment 15 Commit Notification 2019-04-03 15:53:54 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/62ba1f0af72b0c86889a3aea19efd76da3cbe840%5E%21

tdf#108423 autocorrect English word i' -> I’

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.