Bug Hunting Session
Bug 108448 - FILTER:DOC endnotes page gains an extra paragraph each roundtrip
Summary: FILTER:DOC endnotes page gains an extra paragraph each roundtrip
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:6.0.0
Keywords: filter:doc, preBibisect
: 50286 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-10 18:05 UTC by Justin L
Modified: 2018-03-23 09:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
endNote.odt: saving as .doc format adds an empty paragraph each time. (10.66 KB, application/vnd.oasis.opendocument.text)
2017-06-10 18:05 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2017-06-10 18:05:42 UTC
Created attachment 133946 [details]
endNote.odt: saving as .doc format adds an empty paragraph each time.

1.) Open the attached .odt file, and then save as .doc
2.) Close and open .doc file. Formatting isn't right and extra CR.
3.) Save again and repeat.  New CR added during each save.
Comment 1 Xisco Faulí 2017-06-10 18:30:24 UTC
Confirmed in

Version: 5.5.0.0.alpha0+
Build ID: 6ab249ea6aecef5d3f35d624622a368061cad9c3
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Justin L 2017-06-12 13:42:58 UTC
Forgot to mention in the description that this seems to be inherited from OOo - I confirmed back to 3.5 using bibisect43all.
Comment 3 Justin L 2017-06-13 10:56:07 UTC
proposed fix at gerrit.libreoffice.org/38727
Comment 4 Commit Notification 2017-07-01 11:09:36 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e974d24f3bbc59c66476db1a56e6a2013a528e0

tdf#108448 ww8export: skip sectionbreak for endnotes

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-07-01 14:57:05 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=68c8d7faa219b36d5d17ca84f4f1002ec998b80c

tdf#108448 ww8export: endnote unit test

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Justin L 2017-09-06 23:41:23 UTC
*** Bug 50286 has been marked as a duplicate of this bug. ***