Bug Hunting Session
Bug 108461 - A translatable name shouldn't be used to reference the default character style
Summary: A translatable name shouldn't be used to reference the default character style
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
: 114366 (view as bug list)
Depends on:
Blocks: Writer-Styles-Character User-Locale Writer-Toolbar-Formatting-Styles Style-Formatting-Writer-Toolbar
  Show dependency treegraph
 
Reported: 2017-06-11 11:22 UTC by Maxim Monastirsky
Modified: 2018-07-30 13:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Monastirsky 2017-06-11 11:22:08 UTC
Currently the default character style seems to be referenced internally by a translatable string, causing several problems for users of a non-English UI:

- Styles > Default Character menu item doesn't work.

- In some cases, the default style name might be saved into ODT, causing the document to not open properly when the UI lang isn't the same as where it was created. A simple way to reproduce this:

  1) Open Writer with a non-English UI.
  2) Type a word, format it with the "Heading 1" paragraph style.
  3) Insert > Table of Contents and Index > Table of Contents, Index or Bibliography...
  4) Switch to Entries tab, Click on LS button.
  5) For the Character style, select the default style, click OK.
  6) Save the document.
  7) Change the UI lang to something else, and reopen the document.
  8) Notice that the TOC entry has now a different formatting (blue color with an underline).

Expected that the default style will have a non-localizable name, like all other built-in styles, and will return the translatable name only when explicitly asked (via the "DisplayName" property).
Comment 1 Thomas Lendo 2017-08-18 12:25:47 UTC Comment hidden (no-value)
Comment 2 Yousuf Philips (jay) (retired) 2017-12-09 19:48:29 UTC
*** Bug 114366 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2018-07-30 13:34:07 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=94614dc88d78c68d687222d2eb205605e1bd0c51

tdf#108461 Correct use of the default style

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.