Download it now!
Bug 108513 - EDITING: performance regression for changing formatting in a large document
Summary: EDITING: performance regression for changing formatting in a large document
Status: RESOLVED DUPLICATE of bug 112989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, regression
Depends on:
Blocks:
 
Reported: 2017-06-13 21:39 UTC by Telesto
Modified: 2017-11-22 11:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (129.29 KB, application/odt)
2017-06-13 21:39 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-13 21:39:25 UTC
Description:
Performance regression for changing formatting in a large document. However the same issue seems also to occur at file opening. 

Steps to Reproduce:
Option 1 (corresponding with the summary)
1. Open the attached file
2. Select All and apply formatting. Monitor CPU usage

Option 2
1. Download the attached file
2. Make a few copy's of it (4 or 5)
3. Disable Automatic spell checking
3. Open all of them at once, at monitor how long it takes until CPU utilization drops to (nearly zero)

Actual Results:  
CPU is maxed out for 7 seconds with Master, but with LibO4.4.6.3 it's only a 2 seconds

Expected Results:
CPU behavior similar to LibO 4.4.6.3 


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.5.0.0.alpha0+
Build ID: 076ed447f694239d5c67adee528ea6e471d909ff
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-09_23:54:20
Locale: nl-NL (nl_NL); Calc: CL

and in
Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (nl_NL)

a shorter spike in 
Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: nl-NL (nl_NL)

No spike in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-06-13 21:39:51 UTC
Created attachment 134007 [details]
Example file
Comment 2 Buovjaga 2017-06-23 12:51:02 UTC
Yep.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: ab27953d9ef2076e0acd43ed4ba6652732794777
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 23rd 2017

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 3 Telesto 2017-11-22 11:09:49 UTC

*** This bug has been marked as a duplicate of bug 113139 ***
Comment 4 Buovjaga 2017-11-22 11:23:58 UTC

*** This bug has been marked as a duplicate of bug 112989 ***