Download it now!
Bug 108549 - Using Windows Explorer "New" file dialog Calc creates non-standard ODS
Summary: Using Windows Explorer "New" file dialog Calc creates non-standard ODS
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0 all versions
Hardware: All Windows (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-15 07:05 UTC by Sašo Smolej
Modified: 2018-12-25 11:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sašo Smolej 2017-06-15 07:05:59 UTC
Creating a file from within Calc:
1) 1 sheet
2) Localized sheet name
3) Default font is Liberation Sans

Creating a file within Windows:
1) 3 sheets
2) English sheet names (see bug 35912)
3) Default font is Arial

Tested on 5.3.3.2, although I'm pretty sure this has been happening in Libreoffice since I started using it, which was before 4.0.

I presume this is a legacy thing that was never really updated, and it's likely there are further inconsistencies that are not immediately apparent.
It's also an issue in Writer (default font is Times New Roman instead of Liberation Serif) and likely other programs as well, although I haven't created bugs regarding those.

Likely the best fix would be to generate files in share\template\shellnew on install to account for the localization issue. The ones currently there are from 2015.
Comment 1 Buovjaga 2017-06-23 15:17:58 UTC
Repro.

Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: fi-FI (fi_FI); Calc: group
Comment 2 QA Administrators 2018-06-24 02:41:34 UTC Comment hidden (obsolete)
Comment 3 Timur 2018-12-25 11:53:57 UTC
Tested with LO 6.3+ and I didn't reproduce for number of sheets and default font. I'll set WFM. 
Should you reproduce again, please explain.