Bug 108552 - Impress crashes or freezes the desktop when zooming a slide with shapes to 1000% and deeper
Summary: Impress crashes or freezes the desktop when zooming a slide with shapes to 10...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
: 90220 (view as bug list)
Depends on:
Blocks: Zoom-Issues
  Show dependency treegraph
 
Reported: 2017-06-15 12:55 UTC by redshift72
Modified: 2018-06-18 15:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["dxcanvas::BitmapCanvasHelper::clear()"]


Attachments
On slide 4 when I increase and/or decrease zoom, Impress crash or desktop freezes / slow down (17.00 KB, application/vnd.oasis.opendocument.presentation)
2017-06-15 14:26 UTC, redshift72
Details
Callgrind output from master (6.67 MB, application/x-xz)
2017-06-16 10:29 UTC, Buovjaga
Details
Callgrind output from master (6.94 MB, application/x-xz)
2017-06-16 18:56 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description redshift72 2017-06-15 12:55:28 UTC
Description:
On a slide where there is a rectangular figures, when you zoom in a lot, Impress crashes or the desktop (Unity) slows down or stops for a whole few minutes. It also happens if you increase and decrease a few times zoom repeatedly

Steps to Reproduce:
1.create slide with a few rectangular
2.increase a lot the zoom and decrease a lot 
3.may repeat point 2. 


Actual Results:  
4.Impress crash 
5.If Impress dont crash destktop slows down or stops to work for few minutes 

Expected Results:
Simply zooming the slide increases and decreases


Reproducible: Always

User Profile Reset: No

Additional Info:
I test in 
-OS :  ubuntu 16.04 with Unity 
-kernel : 4.8.0-54-generic #57~16.04.1-Ubuntu SMP Wed May 24 16:22:28 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

-CPU : Intel® Core™ i7-6700 CPU @ 3.40GHz × 8 
-GPU : Intel® HD Graphics 530 (Skylake GT2) 


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.86 Safari/537.36
Comment 1 Xisco Faulí 2017-06-15 13:21:42 UTC
I can't reproduce it in

Version: 5.3.3.2
Build ID: 1:5.3.3~rc2-0ubuntu0.16.10.1~lo0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 2 redshift72 2017-06-15 13:34:44 UTC
I confirm bug also after reset user-profile

Versione: 5.3.3.2
Build ID: 1:5.3.3~rc2-0ubuntu0.16.04.1~lo0
Thread CPU: 8; Versione SO: Linux 4.8; Resa interfaccia: predefinito; VCL: gtk2; Motore layout: nuovo; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group
Comment 3 Xisco Faulí 2017-06-15 13:37:36 UTC
Could you please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 4 redshift72 2017-06-15 14:26:07 UTC
Created attachment 134047 [details]
On slide 4 when I increase and/or decrease zoom,  Impress crash or desktop freezes / slow down

On slide 4
when I increase and/or decrease zoom,
 Impress crash or desktop freezes / slow down
Comment 5 Xisco Faulí 2017-06-15 18:16:44 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2017-06-15 18:17:59 UTC
Reproduced in

Versión: 5.3.3.2
Id. de compilación: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
Subproc. CPU: 1; SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group

and

Version: 5.5.0.0.alpha0+
Build ID: 36b1e6270bf2fbb333e2a69c4bb5931eba418289
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-29_14:06:19
Locale: es-ES (es_ES); Calc: group
Comment 7 Xisco Faulí 2017-06-15 18:23:38 UTC
I can also reproduce it in

Versión: 4.4.0.3
Id. de compilación: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Configuración regional: es_ES
Comment 8 Xisco Faulí 2017-06-15 18:36:01 UTC
it also crashes if zooming in the first page. it doesn't crash if the image in the background is deleted
Comment 9 Xisco Faulí 2017-06-15 19:14:29 UTC
It seems the images in the background started to be displayed in commit be7d87bea2611eb316b9b379aebc031179d4f794.
However, I'm not sure that commit is causing the freeze/crash... A callgrind log might help here...
Comment 10 Buovjaga 2017-06-16 10:29:42 UTC
Created attachment 134062 [details]
Callgrind output from master

I did not notice any hang, but here is the callgrind of zooming in and out in slide 4.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: 2802dca10eef67554a81cb2347d5f648fa6fcd63
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: gtk2; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 10th 2017
Comment 11 Buovjaga 2017-06-16 18:56:59 UTC
Created attachment 134069 [details]
Callgrind output from master

You have to zoom in to about 1000% before you start feeling the effects.
I sped up my callgrinding by double clicking the zoom percentage, which opens up a dialog, then I input 1000%, applied and scrolled some more.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 5c81adc51a05a016e754de7961d3a7bdb4494e01
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 16th 2017
Comment 12 Yousuf Philips (jay) (retired) 2017-06-16 19:34:47 UTC
*** Bug 90220 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2018-06-18 15:56:31 UTC
It seems it doesn't crash anymore in

Version: 6.2.0.0.alpha0+
Build ID: d60d695fcc5064e1f16842387fdce23456a64694
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

nor in

Versión: 6.0.4.2
Id. de compilación: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

Besides, no more crashes in recent versions -> https://crashreport.libreoffice.org/stats/signature/dxcanvas::BitmapCanvasHelper::clear()

Closing as RESOLVED WORKSFORME

Much appreciated if someone can doublecheck!!