Download it now!
Bug 108557 - FILEOPEN: DOCX file numbered list has out of sequence number when opened in LibreOffice
Summary: FILEOPEN: DOCX file numbered list has out of sequence number when opened in L...
Status: RESOLVED DUPLICATE of bug 95848
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2017-06-15 23:23 UTC by Gabriel Bowater
Modified: 2019-09-08 21:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File with out of sequence number in numbered list (36.44 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-06-15 23:24 UTC, Gabriel Bowater
Details
PDF showing MS Office rendering sequence vs LO 5.3.3.2 rendering sequence (152.07 KB, application/pdf)
2017-06-15 23:25 UTC, Gabriel Bowater
Details
Screenshot of the example file in current master (342.93 KB, image/png)
2019-09-08 21:34 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Bowater 2017-06-15 23:23:44 UTC
Description:
When opening the attached file in LibreOffice 5.3.3.2, 1-6 in the numbered list are sequenced correctly, but then what should be 7 is instead another 1. After that the previous sequence resumes. 

Steps to Reproduce:
1. Open attached DOCX file
2. Check numbered list
3. The number sequence isn't correct

Actual Results:  
Number 1-6 are sequenced correctly, but then we get a number 1, followed by a resumption of the original sequence

Expected Results:
Numbered list sequence continues uninterrupted 


Reproducible: Always

User Profile Reset: No - replicated on multiple systems

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Gabriel Bowater 2017-06-15 23:24:18 UTC
Created attachment 134053 [details]
File with out of sequence number in numbered list
Comment 2 Gabriel Bowater 2017-06-15 23:25:29 UTC
Created attachment 134054 [details]
PDF showing MS Office rendering sequence vs LO 5.3.3.2 rendering sequence
Comment 3 Xisco Faulí 2017-06-16 08:53:40 UTC
Confirmed in

- Version: 5.5.0.0.alpha0+
Build ID: 6ab249ea6aecef5d3f35d624622a368061cad9c3
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 QA Administrators 2018-06-26 02:44:37 UTC Comment hidden (obsolete)
Comment 5 Gabor Kelemen 2019-09-08 21:34:44 UTC
Created attachment 154028 [details]
Screenshot of the example file in current master

Looks good now in:

Verzió: 6.4.0.0.alpha0+
Build az.: 001f739f1bca7607b0f8cf5f0c7e500dea70db44
CPU szálak: 4; OS: Linux 4.15; Felületmegjelenítés: alapértelmezett; VCL: gtk3; 
Területi beállítások: hu-HU (hu_HU.UTF-8); Felület nyelve: hu-HU
Calc: threaded
Comment 6 Gabor Kelemen 2019-09-08 21:35:16 UTC

*** This bug has been marked as a duplicate of bug 95848 ***