Bug 108565 - LibreOffice QuickStarter not available in Tools > Options > Memory in Fedora
Summary: LibreOffice QuickStarter not available in Tools > Options > Memory in Fedora
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-16 11:58 UTC by Pavel Kovalenko
Modified: 2017-06-19 07:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Kovalenko 2017-06-16 11:58:05 UTC
Description of problem:
libreoffice: unavailable quickstarter

Version-Release number of selected component (if applicable):
LibreOffice Version: 5.2.7.2
ID: 5.2.7.2-3.fc25

How reproducible:


Steps to Reproduce:
1. Install libreoffice (sudo dnf install libreoffice-writer) on Fedora 20 or later (in my case FC25_x64)
2. Start libreoffice (libreoffice --writer)
3. Try to enable QuickStarter (Tools > Options > Memory) 

Actual results:
QuickStarter no longer available in system tray. No such option avaible
Without quickstarter LibreOffice opens files very slowly.
With all enabled tweaks -preload, JavaDisabled, 64Gb of memory - 2 seconds.


Expected results:
QuickStarter should be available in system tray:
https://ask.libreoffice.org/upfiles/14915774457829115.png
With quickstarter LibreOffice opens files instantly.

Additional info:
1. This option is avaible in official docs:
https://help.libreoffice.org/index.php?title=Common/Memory&Version=5.2

2. In Gentoo this was error and was fixed (compilation option)
https://bugs.gentoo.org/show_bug.cgi?id=561842

3. RedHat Support  (Caolan McNamara https://bugzilla.redhat.com/show_bug.cgi?id=1462100):

The systray thing is gtk2 only while we've moved on to gtk3 by default. The full systray set of gtk apis (https://developer.gnome.org/gtk3/stable/GtkStatusIcon.html) fot the systray have been deprecated and the systray concept is deprecated since GNOME3 (https://wiki.gnome.org/Design/OS/MessageTray/Compatibility) so its not practical to reimplement the systray for gtk3. Retaining it for gtk2 only doesn't gain us much.

3. The cost of the lack of options per employee:
   2 seconds * 50 times * 22 working days = 36 minutes
   0.6 hours * 3$ per hour * 12 months = $ 21 per year
Comment 1 Timur 2017-06-16 17:56:35 UTC
Right, QuickStarter not available in Tools > Options > Memory in Fedora 25 with LO 5.2. It's there in Ubuntu.
Comment 2 Caolán McNamara 2017-06-17 20:28:50 UTC
It doesn't make sense to file a bug here upstream that downstream in Fedora we disabled the quick starter under gtk2
Comment 3 David Tardon 2017-06-19 07:45:43 UTC
Btw, QuickStarter is on the chopping block: https://wiki.documentfoundation.org/Proposals_for_removing_features#The_so-called_QuickStarter .