Bug 108630 - FILEOPEN: DOC/DOCX file numbered list sporadically bolding numbers
Summary: FILEOPEN: DOC/DOCX file numbered list sporadically bolding numbers
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOC-Lists-Direct-Formatting DOCX-Lists-Direct-Formatting
  Show dependency treegraph
 
Reported: 2017-06-19 04:56 UTC by Gabriel Bowater
Modified: 2019-06-12 15:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File with numbered list numbers sporadically bolded (21.94 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-06-19 04:57 UTC, Gabriel Bowater
Details
PDF showing MS Office rendering document compared to LO 5.3.3.2 (118.17 KB, application/pdf)
2017-06-19 04:57 UTC, Gabriel Bowater
Details
A minimal test case (3.74 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-07-03 06:55 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Bowater 2017-06-19 04:56:53 UTC
Description:
In the attached file, a few numbered list numbers are bold when opened in LibreOffice 5.3.3.2 but are plain when opened in MS Office 2016

Steps to Reproduce:
1. Open attached file
2. Check file numbers (specifically 14,26, and 27)
3. Numbers appear bold when other numbers in the list are plain.

Actual Results:  
A few numbers are bold.

Expected Results:
All numbered list numbers are plain.


Reproducible: Always

User Profile Reset: No - produced across multiple systems

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Gabriel Bowater 2017-06-19 04:57:23 UTC
Created attachment 134120 [details]
File with numbered list numbers sporadically bolded
Comment 2 Gabriel Bowater 2017-06-19 04:57:55 UTC
Created attachment 134121 [details]
PDF showing MS Office rendering document compared to LO 5.3.3.2
Comment 3 Xisco Faulí 2017-06-19 09:09:13 UTC
Regression introduced by:

author	Luboš Luňák <l.lunak@collabora.com>	2014-05-29 12:31:20 (GMT)
committer	Luboš Luňák <l.lunak@collabora.com>	2014-05-29 12:34:50 (GMT)
commit df07d6cb9f62c0a2c4b29bd850d4efb4fcd4790b (patch)
tree 76d6acc673479866a71f64c1e89756b589c689b4
parent ee0d7d4c52fe93ef2ac73d403f61b642f1ae2716 (diff)
handle direct formatting for numbering in .docx (bnc#875717)

Bisected with bibisect-44max
Comment 4 QA Administrators 2018-06-20 02:48:30 UTC Comment hidden (obsolete)
Comment 5 Mike Kaganski 2018-07-03 06:55:15 UTC
Created attachment 143277 [details]
A minimal test case

Possibly there should be a meta for Word numbering direct formatting, with references to this bug, as well as bug 108630, bug 99474, bug 117994, bug 117923, and maybe more.

The attachment shows that possibly the numbering style takes precedence over manual formatting from CR (w:rPr inside w:pPr). If the settings in numbering.xml contradict the w:rPr inside w:pPr in document.xml, the former take precedence (in the attachment, the setting is the font size: 11 pt in numbering style, and 48 pt in CR properties). Removing the setting from font style activates the CR setting.
Comment 6 Aron Budea 2018-07-08 04:02:45 UTC
With Mike's fix to bug 117923, duplicating Lubos' fix for DOC files, the behavior is the same for DOC files.

DOC sample (created from attachment 134120 [details]): attachment 143269 [details]
Comment 7 Xisco Faulí 2019-01-11 09:50:52 UTC
*** Bug 122032 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2019-06-11 17:06:12 UTC
No longer reproducible in

Versión: 6.2.4.2
Id. de compilación: 2412653d852ce75f65fbfa83fb7e7b669a126d64
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

nor in

Version: 6.4.0.0.alpha0+
Build ID: ec905d131374f0860bac77c52873eed984b1966f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Closing as RESOLVED WORKSFORME
Comment 9 Xisco Faulí 2019-06-12 15:05:13 UTC
This issue got fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=00ac19068de5e120d1620a719aa64f1203c639ae, which is the fix for bug 120548