Bug Hunting Session
Bug 108682 - DOCX import: negative line spacing is mis-interpreted
Summary: DOCX import: negative line spacing is mis-interpreted
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-21 15:42 UTC by Miklos Vajna
Modified: 2017-06-28 14:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer document. (12.36 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-06-21 15:42 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2017-06-21 15:42:03 UTC
Created attachment 134201 [details]
Reproducer document.

See the attached document. Check the paragraph line spacing of the only line in the document.

Expected: line spacing is the same as in MSO: it's exactly 13pt.

Actual: line spacing is 200%. When saved to ODF, it's even worse: fo:line-height is "-108%".
Comment 1 Timur 2017-06-22 15:14:55 UTC
OO was 148%. Looks like changed in 4.2 to 200%. Same as Bug 86371.
Comment 2 Commit Notification 2017-06-22 16:58:32 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f575f70b8303ba187f6989920281ff02e7a431c9

tdf#108682 DOCX import: fix <w:spacing w:line=...> for negative values

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Miklos Vajna 2017-06-22 19:51:44 UTC
Please close bug 86371 as duplicate if it is indeed also fixed by the above commit. Thanks!
Comment 4 Timur 2017-06-28 14:35:29 UTC
This one verified. Bug 86371 not a duplicate.