Download it now!
Bug 108803 - Customizing toolbar icons does not work
Summary: Customizing toolbar icons does not work
Status: RESOLVED DUPLICATE of bug 106784
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-06-27 04:06 UTC by kavalec74
Modified: 2018-03-01 13:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
customize - change icon dialog (74.72 KB, image/png)
2017-06-27 04:06 UTC, kavalec74
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kavalec74 2017-06-27 04:06:36 UTC
Created attachment 134304 [details]
customize - change icon dialog

I tried to change a toolbar icon, the result was: it apeared in the menu of visible icons, but not on the toolbar.

Also change the recomanded icon size of the icon from 26px to 16px in the note (see attached screenshot)

This bug refers to LO 5.4 beta 2, I did not know, what component have I to chooze.
Comment 1 Xisco Faulí 2017-06-27 09:29:58 UTC Comment hidden (obsolete)
Comment 2 kavalec74 2017-06-27 16:23:00 UTC
Steps to reproduce the bug:

1. right click on standard toolbar > Costumize Toolbat 
2. in the Toolbar Content select the icon you want to modify
3. click the button Modify > Change icon
4. select a new image for of icon 16 x 16 px
5. select the imported icon image in the list of installed icons
6. click OK to close the dialog
7. click OK to close the Customize window
Comment 3 Julien Nabet 2017-06-27 20:31:54 UTC
On pc Debian x86-64 with master sources updated yesterday, I culd reproduce this.

In dialog box, the icon changes but not in the UI even after having restarted LO.
Comment 4 kavalec74 2017-06-27 21:26:17 UTC
Today I downladed the "Testing"-version, the bug is still there, which is logic of course.
Comment 5 Julien Nabet 2017-06-28 07:18:03 UTC
Muhammet: noticing your work about revamping customization dialog, thought you might be interested in this one.
It'd be great if a quick fix could be found for this one!
Comment 6 kavalec74 2017-07-04 07:46:59 UTC
Just tested in 5.2.7.2 it works there.

(the recommanded icon size is there 26 x 26, which has been changed to 16 x 16 in 5.4)
Comment 7 raal 2017-07-23 21:05:13 UTC
This seems to have begun at the below commit.
Adding Cc: to Tomaž Vajngerl ; Could you possibly take a look at this one?
Thanks

0c820fc5a1446e9cc151c1f89793c6dab056af16 is the first bad commit
commit 0c820fc5a1446e9cc151c1f89793c6dab056af16
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon Oct 31 22:08:26 2016 +0100

    source sha:c3043a3072465c489d3b20991b17d222771305eb

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2016-10-31 12:28:26 (GMT)
committer	Tomaž Vajngerl <quikee@gmail.com>	2016-10-31 14:49:57 (GMT)
commit	c3043a3072465c489d3b20991b17d222771305eb (patch)
tree	8981124cc9435802c72e1123d5e16a404e4d239f
parent	7de287ba422107f54018f2ba0f054d642c86c966 (diff)
tdf#103591 icon theme name resolving, ui fixes, prioritize png
Comment 8 Maxim Monastirsky 2018-03-01 13:50:48 UTC

*** This bug has been marked as a duplicate of bug 106784 ***