Bug Hunting Session
Bug 108832 - Ubuntu hosted VirtualBox Windows 7 VM has disappearing text from dialogs and buttons
Summary: Ubuntu hosted VirtualBox Windows 7 VM has disappearing text from dialogs and ...
Status: RESOLVED DUPLICATE of bug 107166
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.2.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-28 11:54 UTC by grofaty
Modified: 2017-08-03 07:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
disappearing_text.gif (1.44 MB, image/gif)
2017-06-28 11:54 UTC, grofaty
Details
SystemInformation_Components_Display_print-screen.png (39.34 KB, image/png)
2017-06-29 06:51 UTC, grofaty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2017-06-28 11:54:26 UTC
Created attachment 134342 [details]
disappearing_text.gif

Hi,
using LibreOffice Calc 5.3.4.2 on Windows 7. I have recorded video of several problems when text just disappears from dialogs.
Problem in my video recording are ALWAYS reproducible on my PC. Beside those problems are plenty of additional disappearing text problems that I can't always reproduce, but are appearing time to time like "Sheet1" tab (at the bottom) losing text (just empty tab without text) and similar.

I have been using LibreOffice for years actually from day 1 of first release and I installed many of the LibreOffice versions on my computer over time and have never seen this problem before. It started appearing in 5.3.3. Before I have been using 5.2.x, I don't like to install LibreOffice when it gets out, I always wait e.g. 3 fixes on stable version.
Regards
Comment 1 Xisco Faulí 2017-06-28 15:30:45 UTC Comment hidden (obsolete)
Comment 2 Xisco Faulí 2017-06-28 16:11:36 UTC
Actually it looks more like a duplicate of bug 105863

*** This bug has been marked as a duplicate of bug 105863 ***
Comment 3 Aron Budea 2017-06-28 16:31:22 UTC
I'd opt for bug 107166.

*** This bug has been marked as a duplicate of bug 107166 ***
Comment 4 V Stuart Foote 2017-06-28 17:32:50 UTC
Yes this is a duplicate of 107166, first screens of the gif show OP not in OpenGL mode, so this is not bug 107764

from the video...

Version: 5.3.4.2 (x64)
Build ID: f82d347cco0be322489bf7da61d7e4ad13fe2ff3
CPU Threads: 3; OS Version: Windows 6.1: UI Render: default; Layout Engine: new;
Locale: sl-SI (sl_SI); Calc:group
Comment 5 grofaty 2017-06-29 06:30:18 UTC
I have made several tests:
1. In existing version (5.3.4.2) deleted profile, so I deleted subfolder of C:\Users\[user]\AppData\Roaming\LibreOffice\
2. Tools | Options | LibreOffice | View | Graphics Output | unchecked all of the options
3. Closed down LibreOffice.
4. Deleted profile again (step 1).
5. From Windows Task Manager (Show processes from all users) kill soffice.bin to make sure LibreOffice is really down.
6. Restarted and Edit | "Find & Replace" and there is no text in front of input boxes (just like in the video).

So new profile, everything related to hardware accelerations turned off problem remains.

Now decided to ping pong the problem.
Downloaded nightly from http://dev-builds.libreoffice.org/daily/ the same problem. And then downloading installing version after version from https://downloadarchive.documentfoundation.org/libreoffice/old/

Bellow is the result of my testing. From my testing it is clear the problem got into existence between version 5.3.1.2 (working fine - Edit | Find & Replace showing labels in front of input boxes) and 5.3.2.1 (problems appear exactly the same as in the recorded video).

I have read the bugs marked as duplicate:
Bug 107764 - I don't have File, Edit, View - missing, there are perfectly well displayed.
Bug 105863 - I don't have flickering problem of menus
Bug 107166 - It behaves like this problem, but my menus are fine, just at some points (like Edit | Find & Replace or Tools | Options | LibreOffice | User Data all data are blank).


--------------------------------
WORKS FINE

Version: 5.2.7.2 (x64)
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
CPU Threads: 3; OS Version: Windows 6.1; UI Render: default; 
Locale: sl-SI (sl_SI); Calc: group
--------------------------------
WORKS FINE

Version: 5.3.0.0.alpha1 (x64)
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 3; OS Version: Windows 6.1; UI Render: default; 
Locale: sl-SI (sl_SI); Calc: group
--------------------------------
WORKS FINE

Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 3; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: sl-SI (sl_SI); Calc: group
--------------------------------
PROBLEM

Version: 5.3.2.1 (x64)
Build ID: 7f6693c08cc110b9721245fc4bd4f1712e0c086c
CPU Threads: 3; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: sl-SI (sl_SI); Calc: group
--------------------------------
PROBLEM

Version: 5.3.2.2 (x64)
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU Threads: 3; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: sl-SI (sl_SI); Calc: group
--------------------------------
PROBLEM

Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 3; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: sl-SI (sl_SI); Calc: group
--------------------------------
PROBLEM --> tested yesterday when reporting a bug

Version: 5.3.4.2 (x64)
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
CPU Threads: 3; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: sl-SI (sl_SI); Calc: group
--------------------------------
PROBLEM

Version: 6.0.0.0.alpha0+
Build ID: 068755d9313b61a1e4691c27eea122116d3623df
CPU threads: 3; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-29_00:58:30
Locale: sl-SI (sl_SI); Calc: group
--------------------------------
Comment 6 V Stuart Foote 2017-06-29 06:38:21 UTC
@grofaty, thankyou for the additional data. Clearly a duplicate of bug 107166. 

The only missing detail of your situation would be to run "msinfo32.exe" and post the text from the Components -> Display panel.  That will show the GPU and the driver in use that is experiencing the issue.
Comment 7 grofaty 2017-06-29 06:51:56 UTC
Created attachment 134372 [details]
SystemInformation_Components_Display_print-screen.png

I am attaching System Information -> Components -> Display panel.
Comment 8 V Stuart Foote 2017-06-29 06:59:15 UTC
OK, partly there-- virtual handling with vboxvideo.sys 4.3.38.0 on Ubuntu 14.04.5 LTS--but what is the GPU and driver for the Linux host system?
Comment 9 grofaty 2017-06-29 07:12:25 UTC
On Ubuntu host I executed: sudo lshw -c video


  *-display               
       description: VGA compatible controller
       product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:28 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)
Comment 10 grofaty 2017-08-03 07:02:43 UTC
I downloaded LibreOffice 5.4.0.3 today and installed on Windows 7. I tested this bug report and I problem is fixed. Thanks a lot.

Help | About info:
Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 3; OS: Windows 6.1; UI render: default; 
Locale: sl-SI (sl_SI); Calc: group