Bug 108833 - CRASH: When changing the template style of a large set of slides for a second time
Summary: CRASH: When changing the template style of a large set of slides for a second...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+ Master
Hardware: All Windows (All)
: medium normal
Assignee: Michael Stahl
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.0.2
Keywords:
Depends on:
Blocks: Undo-Zero-Steps
  Show dependency treegraph
 
Reported: 2017-06-28 11:55 UTC by Telesto
Modified: 2017-07-26 16:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (18.60 KB, application/vnd.oasis.opendocument.presentation)
2017-06-28 12:37 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-28 11:55:58 UTC
Description:
Crash when changing the template style of a large set of slides for a second time

Steps to Reproduce:
1. Open the attached file
2. Select all slides in the slide pane
3. Click Master Pages in the sidebar.
4. Select a random template and apply (wait until until Libo is responsive again)
5. Repeat step 4 a second time -> Crash

Actual Results:  
Crash

Expected Results:
No crash


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: 9f3814af7264ce90685a82cbf4eb015a38f22bf7
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-28_00:47:42
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 5.4.0.0.beta2 
Build ID: 3cc1cdd8ee50f144e5514da51800a08119754d8f
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Xisco Faulí 2017-06-28 12:22:11 UTC
no attachment attached
Comment 2 Telesto 2017-06-28 12:37:23 UTC
Created attachment 134347 [details]
Example file

Forgotten; again =)
Comment 3 Xisco Faulí 2017-06-28 13:59:03 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: cb37c5f0f3de7b545231a53d46a5271058af76ad
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-23_06:55:41
Locale: es-ES (es_ES); Calc: group

and in

Version: 6.0.0.0.alpha0+
Build ID: 7931ef2abbcef22de5cdddd26738e4dd8d1d8ca5
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

it freezes but it doesn't crash
Comment 4 Xisco Faulí 2017-06-28 14:02:06 UTC
I will report the freeze in another issue as it look to be only in gtk/gtk3.
I can't reproduce the crash in

Version: 6.0.0.0.alpha0+
Build ID: 7931ef2abbcef22de5cdddd26738e4dd8d1d8ca5
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 5 Telesto 2017-06-28 15:21:08 UTC
Setting to Windows only
Comment 6 Buovjaga 2017-06-29 19:10:43 UTC
I can do two changes without a crash. I even did four.
It doesn't seem to be about running out of mem, because it stays at around 120M.

Can you get a Windbg trace? https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg

Version: 6.0.0.0.alpha0+ (x64)
Build ID: e0f67add2ec56706ce06a03572535266f21c0303
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-06-27_23:04:56
Locale: fi-FI (fi_FI); Calc: group
Comment 7 Telesto 2017-06-29 21:45:30 UTC
(In reply to Buovjaga from comment #6)
> I can do two changes without a crash. I even did four.

And sadly I know now why. It crashes when undo count is set to zero before doing the template changes: Set the undo count to zero (https://help.libreoffice.org/Common/Memory#Number_of_undo_steps)

crashreport.libreoffice.org/stats/crash_details/bfcac6e5-af19-49c0-b96f-03538f0161ac
Comment 8 Buovjaga 2017-06-30 12:17:29 UTC

*** This bug has been marked as a duplicate of bug 108863 ***
Comment 9 Commit Notification 2017-06-30 15:17:00 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d59018b1ed816b4399cad4c2c4818cf25d4f4a1

tdf#108833 sd: don't unconditionally enable Undo after import

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Michael Stahl 2017-06-30 15:24:22 UTC
fixed on master
Comment 11 Commit Notification 2017-07-04 10:31:59 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6e84702699ce8c48ae669d9d50aa56f78a05ea1&h=libreoffice-5-4

tdf#108833 sd: don't unconditionally enable Undo after import

It will be available in 5.4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.