Bug 108932 - FILESAVE as .docx: caption hidden by shrunk textbox
Summary: FILESAVE as .docx: caption hidden by shrunk textbox
Status: RESOLVED DUPLICATE of bug 106153
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2017-07-04 01:18 UTC by Justin L
Modified: 2020-09-09 14:11 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The exported version of the document reopened in Writer (146.18 KB, image/png)
2020-09-09 14:11 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2017-07-04 01:18:53 UTC
When attachment 132901 [details] is saved as .docx, then the caption on the first image (on page 2) has a hidden caption.

1. Save testdoc01-cmi2.odt in .docx format
2. Open testdoc01-cmi2.docx and notice the red arrow indicating hidden text on the first image frame.

Regression introduced in LibreOffice 5.0's fix for bug 91260 by
László Németh 2015-05-13 15:47:36
commit a4dee94afed9ade6ac50237c8d99a6e49d3bebc1
tdf#91260: allow textboxes extending beyond the page bottom
Comment 1 Justin L 2017-07-04 01:23:38 UTC
CC'd  László
Comment 2 Xisco Faulí 2017-07-04 09:12:34 UTC Comment hidden (obsolete)
Comment 3 Justin L 2017-07-04 12:31:06 UTC
(In reply to Xisco Faulí from comment #2)
> Is it the same as bug 106153 ?

No, that one describes a very different, non-regression problem - primarily concerned with UI, while this one is a regression causing hidden content.
Comment 4 Cristóbal Tapia 2017-07-05 08:38:10 UTC
I can confirm this in LibreOffice 5.3.1
Comment 5 Justin L 2017-08-17 16:16:59 UTC
proposed fix https://gerrit.libreoffice.org/40558
Comment 6 Commit Notification 2017-08-31 18:12:07 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b55d86610128d0b6f8d0fea7c9a3e9d5acd4c878

tdf#108932 - prevent textbox shrink from actually growing

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2017-09-27 01:59:56 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=892c719fffa06de4c7aeab497326cad7bae9e5c6

Revert "tdf#108932 - prevent textbox shrink from actually growing"

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Justin L 2017-09-27 03:34:14 UTC
My trial fix in comment 6 caused a regression as bug 112515, so it has been reverted. Removing myself from this bug and re-opening.
Comment 9 Timur 2019-03-27 14:46:26 UTC
Repro 6.3+
Comment 10 sdc.blanco 2019-10-28 12:19:11 UTC
Can confirm with Version: 6.3.3.1 (x64), using .odt file in attachment 132901 [details].

One additional observation:  

Before saving the file as .docx, the frames (Marco1, Marco3, Marco4) are listed under "Text frames" in Navigator.  After saving as .docx and reloading, these frames are now listed under "Drawing objects".

Maybe that is significant?
Comment 11 Justin L 2020-07-25 11:00:26 UTC
(In reply to Justin L from comment #8)
> My trial fix in comment 6 caused a regression as bug 112515, so it has been
> reverted.
Not reverting my jenkins comment that "Actually, I think that
the regression commit ought to be fully reverted. It "fixes" such
a strange situation and seems to have a lot of unintended
repercussions. Just look at tdf#91260 and see all of the
additional patches."
Comment 12 NISZ LibreOffice Team 2020-09-09 14:11:06 UTC
Created attachment 165323 [details]
The exported version of the document reopened in Writer

This got better recently with:

https://git.libreoffice.org/core/+/b6850bbe95418ecfde404be1696548f18d200c9b

author
Attila Bakos <bakos.attilakaroly@nisz.hu> Thu Aug 06 13:49:43 2020 +0200 
committer
László Németh <nemeth@numbertext.org> Fri Aug 21 23:48:33 2020 +0200 

tdf#106153 sw compatibility: fix textboxes exceeding the page
Comment 13 NISZ LibreOffice Team 2020-09-09 14:11:48 UTC
Thanks Attila for fixing this!

*** This bug has been marked as a duplicate of bug 106153 ***