Bug 108986 - PIVOT CHARTS: drop down list arrow shouldn't appear on "Data" button in the pivot chart controls
Summary: PIVOT CHARTS: drop down list arrow shouldn't appear on "Data" button in the p...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Dennis Francis
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.1
Keywords:
Depends on:
Blocks: Pivot-Chart
  Show dependency treegraph
 
Reported: 2017-07-06 08:15 UTC by bureautiquelibre
Modified: 2017-07-12 10:02 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Pivot chart example with Data information shown (22.58 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-07-06 08:15 UTC, bureautiquelibre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bureautiquelibre 2017-07-06 08:15:51 UTC
Created attachment 134510 [details]
Pivot chart example with Data information shown

Hi,

Since there is no dropdown menu associated to "Data" (and no associated control), there should be no arrow there.

Also it shouldn't be formatted the same way as dropdown list controls since it doesn't expose any action for the user.

Regards,
Eric Ficheux
Comment 1 Dennis Francis 2017-07-07 07:00:56 UTC
Can reproduce.

Version: 6.0.0.0.alpha0+
Build ID: 21ef36fc5f71a8d90029000be65988ce5a14e503
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group
Comment 2 Commit Notification 2017-07-10 13:40:32 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c86be45d343635f2e137b8ea710d87e1a612101d

tdf#108986 : no arrow for "Data" button on pivot chart

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2017-07-12 10:02:02 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8c99a081676dff667710f842ea8ed7cc0086b5f&h=libreoffice-5-4

tdf#108986 : no arrow for "Data" button on pivot chart

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.