Bug 109053 - DOCX: Multipage table is not imported properly - fix by avoid floating table conversion
Summary: DOCX: Multipage table is not imported properly - fix by avoid floating table ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.1 target:5.3.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2017-07-10 18:24 UTC by Tamás Zolnai
Modified: 2017-07-19 20:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with a multipage table (11.91 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-07-10 18:24 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-07-10 18:24:34 UTC
Description:
The test document (created based on a real life document) contains a table positioned on two pages. If I open it in Writer I get only a one page document with a smaller table on the first page.

Steps to Reproduce:
1. Open attached document
2. Check the pages size and the table

Actual Results:  
Only one page is imported with a smaller table on it.

Expected Results:
The whole table should be imported with the two pages.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Comment 1 Tamás Zolnai 2017-07-10 18:24:56 UTC
Created attachment 134577 [details]
Document with a multipage table
Comment 2 Xisco Faulí 2017-07-10 19:27:00 UTC
Regression introduced in

author	Cédric Bosdonnat <cedric.bosdonnat@free.fr>	2013-02-20 10:04:16 (GMT)
committer	Cédric Bosdonnat <cedric.bosdonnat@free.fr>	2013-02-20 10:17:00 (GMT)
commit	d0cde9640b52ccfbb28ed1f65bba0927afd7b69b (patch)
tree	18c6342798d98ff8559a3cf26dac4994a2f82998
parent	a633a96c3a50d803e5fa43b603edc0b8e2e34b6e (diff)
n#779642: Fixed floating tables import in writerfilter

Bisected with bibisect-41max

bug 99822 is affected by the same commit.
Comment 3 Commit Notification 2017-07-12 17:04:21 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fc55711f01af172eb3a034454405fa941454c781

tdf#109053: DOCX: Multipage table is not imported properly

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Timur 2017-07-13 09:30:38 UTC
Looks like fixed. 
I update the title to discriminate among different multipage issues. 
4.0 and 4.1 are known for other floating table and wrap around bugs.
Comment 5 Commit Notification 2017-07-14 06:45:13 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=92dc49a206dee0c157c57e5458a69365effa981f&h=libreoffice-5-4

tdf#109053: DOCX: Multipage table is not imported properly

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-07-14 11:01:31 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=961afc771228c77c355a0c5fd8ff051e7e241bd2&h=libreoffice-5-3

tdf#109053: DOCX: Multipage table is not imported properly

It will be available in 5.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2017-07-19 20:53:17 UTC
Verified in

Version: 6.0.0.0.alpha0+
Build ID: bde72cdae1e7e001d5089c5284672c976b8e43df
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group