Bug 109142 - Tibetan long U not correctly rendered
Summary: Tibetan long U not correctly rendered
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.1 rc
Hardware: All All
: medium normal
Assignee: Khaled Hosny
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.2
Keywords:
Depends on: HarfBuzz
Blocks: hb_ot_math HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2017-07-16 08:15 UTC by Volga
Modified: 2017-08-27 16:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (8.85 KB, application/vnd.oasis.opendocument.text)
2017-07-16 08:16 UTC, Volga
Details
Microsoft Himalaya font (311.70 KB, application/x-zip-compressed)
2017-08-10 03:07 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-07-16 08:15:17 UTC
Description:
In LibreOffice, Tibetan syllable long U (ཨཱུ) not works as expected.

Steps to Reproduce:
1. Copy & paste Tibetan texts from http://digitaltibetan.org/index.php/Tibetan_Unicode_Test_Page
2. Set the font face as Microsoft Himalaya

Actual Results:  
With MS Himalaya font the order of two vowel signs (U+0F71, U+0F74) looks mixed up.

Expected Results:
Tibetan texts should be rendered as expected as http://digitaltibetan.org/index.php/File:Vajragurusample.jpg


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Volga 2017-07-16 08:16:13 UTC
Created attachment 134657 [details]
Test file
Comment 2 Volga 2017-07-17 02:52:22 UTC
HarfBuzz have already fixed this bug, so we can waiting for new version of HarfBuzz and then intergrated it.
Comment 3 Xisco Faulí 2017-07-17 09:44:29 UTC
(In reply to Volga from comment #2)
> HarfBuzz have already fixed this bug, so we can waiting for new version of
> HarfBuzz and then intergrated it.

Which version is it ?
Comment 4 Volga 2017-07-19 17:25:33 UTC
(In reply to Xisco Faulí from comment #3)
> (In reply to Volga from comment #2)
> > HarfBuzz have already fixed this bug, so we can waiting for new version of
> > HarfBuzz and then intergrated it.
> 
> Which version is it ?

1.4.7, it is released not so long time.
Comment 5 Elie Roux 2017-08-08 07:46:50 UTC
Link to the Harfbuzz issue: https://github.com/behdad/harfbuzz/issues/417
Comment 6 Volga 2017-08-10 03:07:22 UTC
Created attachment 135390 [details]
Microsoft Himalaya font
Comment 7 Volga 2017-08-11 10:43:55 UTC
(In reply to Volga from comment #4)
> (In reply to Xisco Faulí from comment #3)
> > (In reply to Volga from comment #2)
> > > HarfBuzz have already fixed this bug, so we can waiting for new version of
> > > HarfBuzz and then intergrated it.
> > 
> > Which version is it ?
> 
> 1.4.7, it is released not so long time.

Now all versions of HarfBuzz starting to 1.4.7 including this bug fix.
Comment 8 Khaled Hosny 2017-08-13 21:29:14 UTC
https://gerrit.libreoffice.org/#/c/41124/
Comment 9 Volga 2017-08-14 15:53:05 UTC
With this bug fix we will also fix ZWNJ handling for many other Brahmic scripts, sightly affect Gujarati, Kannada, Khmer and Tamil. HarfBuzz including the following bug fix since v1.4.7:

https://cgit.freedesktop.org/harfbuzz/commit/?id=e359a4b8f57bbc778843f233c4f5d6fb07ff11d9
Comment 10 Commit Notification 2017-08-15 11:03:32 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5aab2900dfdc9f12adda378470149670a2a069df

tdf#109142: Update to HarfBuzz 1.4.8

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Volga 2017-08-15 13:03:40 UTC
Is it possible to back port to 5.4 branch?
Comment 12 Khaled Hosny 2017-08-16 11:48:54 UTC
(In reply to Volga from comment #11)
> Is it possible to back port to 5.4 branch?

https://gerrit.libreoffice.org/#/c/41210/
Comment 13 Commit Notification 2017-08-16 20:21:46 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ddba061b07e55dfd2c91320ca790ff88618b132c&h=libreoffice-5-4

tdf#109142: Update to HarfBuzz 1.4.8

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.